Probleme beim Ubuntu-Join

german
ubuntu

#1

Hallo zusammen,

ich versuche gerade einen Ubuntu-Client (KDE-Neon-Rolling Release based on Ubuntu 16.04) an UCS anzubinden. Den Client habe ich vorher am Server als “Ubuntu” bereits angelegt und bin anschließend nach der Anleitung vor gegangen. Die ersten beiden Skript habe ich gemäß Kapitel 1.1 ausgeführt. Hier habe ich lediglich die IP des Masters angepasst.

Beim Aufruf des 2. Skripts erhalte ich:

temp@tuxlap:~$ sh skript2.sh 
--2018-01-07 13:46:50--  http://tux.gehr.lan/ucs-root-ca.crt
Auflösen des Hostnamen »tux.gehr.lan (tux.gehr.lan)«... 192.168.24.5
Verbindungsaufbau zu tux.gehr.lan (tux.gehr.lan)|192.168.24.5|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 2009 (2,0K) [application/x-x509-ca-cert]
In »»/etc/univention/ssl/ucsCA/CAcert.pem«« speichern.

/etc/univention/ssl/ucsCA/CAcert.pem            100%[=======================================================================================================>]   1,96K  --.-KB/s    in 0s      

2018-01-07 13:46:50 (99,0 MB/s) - »/etc/univention/ssl/ucsCA/CAcert.pem« gespeichert [2009/2009]

The authenticity of host 'tux.gehr.lan (192.168.24.5)' can't be established.
ECDSA key fingerprint is SHA256:U19Z1cxlRpZCveMN6zN3vu7d0LqGOBpp9rVZ8KTg+Qo.                                                                                                                    
Are you sure you want to continue connecting (yes/no)? yes                                                                                                                                      
Warning: Permanently added 'tux.gehr.lan' (ECDSA) to the list of known hosts.                                                                                                                   
Password:                                                                                                                                                                                       
E: Object exists: (uid) : tuxlap$  

Kommt dies weil ich den Client bereits angelegt habe? Sollte ich das nicht tun?

Das letzte Skript habe ich gemäß:

https://help.univention.com/t/probleme-beim-domanenbeitritt-eines-mint-systems/2945

ausgeführt. Wenn ich anschließend “getent passwd” oder “getent group” ausführe sehe ich allerdings keine Domain-User oder -Gruppen.

Was habe ich übersehen?

Viele Grüße
Sven


#2

Ok, wenn man das Rechner-Objekt nicht vorher anlegt dann laufen die Skripte bis bis zum Vorletzten in Kapitel 1.3 durch. Beim letzten erhalte ich die Fehlermeldung:

[sudo] Passwort für temp: 
mkdir: das Verzeichnis »/etc/lightdm/lightdm.conf.d“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
bash: Zeile 4: /etc/lightdm/lightdm.conf.d/99-show-manual-userlogin.conf: Datei oder Verzeichnis nicht gefunden

Ich vermute mal einfach das KDE Plasma nicht lightdm verwendet. Ich bin nicht unbedingt ein Profi in Sachen Login-Manager. Weiß jemand wie ich das Skript für KDE NEon anpassen muss damit es funktioniert?

Viele Grüße
Sven


#3

Mit der Config sollte es funktionieren:

$ cat /etc/sddm.conf 
[Autologin]
Relogin=false
Session=
User=

[General]
HaltCommand=
RebootCommand=

[Theme]
Current=circles
CursorTheme=breeze_cursors

[Users]
MaximumUid=65000
MinimumUid=1000

#4

Danke, gerade Feierabend gemacht. Werde ich Morgen gleich mal im Büro testen.


#5

Das bedeutet ich lasse dass Skript;

# Become root
sudo bash

# Add a field for a user name, disable user selection at the login screen
mkdir /etc/lightdm/lightdm.conf.d
cat >>/etc/lightdm/lightdm.conf.d/99-show-manual-userlogin.conf <<__EOF__
[SeatDefaults]
greeter-show-manual-login=true
greeter-hide-users=true
__EOF__

# Exit sudo bash
exit

ersatzlos weg und erstelle die Datei wie von dir gezeigt? Habe ich gemacht. Wenn ich nun boote erscheint eine bildschirmfüllende Tastatur ?


#6

Das ist seit längerem normal bei SDDM unter neon. Die kriegt man problemlos weg (per ESC oder so, ich logge mich nicht sof neu ein und weiß es daher nicht genau).

Das Script läßt du dann natürlich weg ja.