Problem with GPG key installing OpenProject

I am currently in the process of trying to install OpenProject on a fresh instance of UCS 5.0

When I run ‘univention-app install openproject’ I get errors looking like this:

W: GPG error: https://updates.software-univention.de/4.2/maintained 4.2-5/amd64/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D293E501A055F562
E: The repository 'https://updates.software-univention.de/4.2/maintained 4.2-5/amd64/ Release' is not signed.

When I run ‘apt-key list’ I get this:

/etc/apt/trusted.gpg.d/univention-archive-key-ucs-3x.gpg
--------------------------------------------------------
pub   dsa1024 2011-10-05 [SC] [expired: 2018-10-03]
      3550 FB4C C61F DB88 D334  E31A 1DD6 7AFB 2CBD A4B0
uid           [ expired] Univention Corporate Server 3.x Archive Key <packages@univention.de>

/etc/apt/trusted.gpg.d/univention-archive-key-ucs-4x.gpg
--------------------------------------------------------
pub   rsa4096 2014-06-30 [SC] [expired: 2021-06-28]
      6B6E 7E32 59A9 F44F 1452  D1BE 3660 2BA8 6B8B FD3C
uid           [ expired] Univention Corporate Server 4.x <packages@univention.de>

/etc/apt/trusted.gpg.d/univention-archive-key-ucs-5x.gpg
--------------------------------------------------------
pub   rsa4096 2020-05-08 [SC] [expires: 2027-05-07]
      8321 745B B32A 82C7 5BBD  4BC2 D293 E501 A055 F562
uid           [ unknown] Univention Corporate Server 5.x <packages@univention.de>

I have been looking at this post:

And tried the solution, but only the dirty workaround works…

If you can advice, I’d much appreciate :slight_smile:
Noa