Problem: Squid gets slow an hits Error Message kid1| WARNING! Your cache is running out of filedescriptors

Problem

After some time, squid gets slower and you can find the following message in squid-log:

kid1| WARNING! Your cache is running out of filedescriptors

Solution

You can increase the max filedescriptors by setting it in the file /etc/squid/local_bottom.conf:

/etc/squid/local_bottom.conf:

max_filedescriptors 4096

after that, please restart squid

root@example:~# systemctl restart squid
root@example:~#