Problem: slapd does not start if loglevel is to high

Problem

If trying to start slapd with systemctl start slapd or systemctl restart slapd, the attempt fails due to a timeout

Environment

The Loglevel of slapd is set to a very high loglevel or is set to debug

Solution

Change the loglevel to a lower value and try the (re)start again:

root@example:~# ucr set ldap/debug/level=none
Setting ldap/debug/level
Multifile: /etc/ldap/slapd.conf
root@example:~# systemctl restart slapd
root@example:~#

Root Cause

Because the loglevel is set too high, slapd takes too long to start and systemd aborts the attempt because the timeout threshold is exceeded.