Problem: OVA Image not able to Join Domain during Installation

join
vmware
installation
problem

#1

Problem

When installing an additional server based on the current (as of 7th September 2018) VMware ova-image the join process fails when selected to join the domain after installation.

Environment

Affected is at least:

sha1sum UCS-VMware-ESX-Image.ova 
709bb1d1b4c8ee872ca62a33d0b2e431c0a30ac8  UCS-VMware-ESX-Image.ova

In the join.log you might find error messages like this:


Thu Sep  6 13:03:31 CEST 2018: starting /usr/sbin/univention-join -dcname master.domain.com -dcaccount Administrator -dcpwd /var/cache/univention-system-setup/secret -checkPrerequisites
running version check
OK: UCS version on master.domain.com is higher or equal (4.32) to the local version (4.32).
Thu Sep  6 13:03:38 CEST 2018: finish /usr/sbin/univention-join
Thu Sep  6 13:06:02 CEST 2018: starting /usr/share/univention-join/univention-join -dcaccount Administrator -dcpwd /tmp/tmp.ZtengP2cMn


**************************************************************************
* Join failed!                                                           *
* Contact your system administrator                                      *
**************************************************************************
* Message:  Please visit https://help.univention.com/t/8842 for common problems during the join and how to fix them -- missing dns service record for _domaincontroller_master._tcp.domain.com
**************************************************************************
Thu Sep  6 13:06:22 CEST 2018: finish /usr/share/univention-join/univention-join

Solution

During installation, do NOT select the “join domain after installation”. Reboot the system once installation is done. Then logon to the systems web-ui UMC as “root” (Administrator won’t work as it is not joined yet) with the given password and join the system through UMC. Join will work then.


#2