Problem: Onlyoffice + Nextcloud VM - No web interface of nextcloud after installation

onlyoffice
nextcloud

#1

I have download the VM file of UCS-onlyoffice with nextcloud appliance from here.

  • Imported the VM into VMware fusion 11.

  • Started the VM and completed the configuration (I chose Joining existing Active Directory.)

  • Waiting until the installation finished. Everything is OK so far. No error information.

Reboot…

Then the PROBLEM comes … When I open the server’s address with my safari, there is no nextcloud web interface icon, even no Applications section in the Univention Portal. Here is the captured screen.
08

No “ONLYOFFICE Document Server & Nextcloud web interface” at all …
How can I get to the Nextcloud web interface?

I have re-downloaded the VM and repeated it in my windows server. All the same…

Is it a bug?
I am new with UCS. Could someone kindly tell me what the problem is and how to fix it?
Many thanks!


#2

Update of the problem:

If I choose to create a new domain locally rather than join an existing AD Domain, the problem solved. Here is the captured screen.
38

It seems that this app pack is not compatible with the configuration of joining an existing AD Domain.

By the way, the version of Nextcloud in this combo VM is 14… whereas the newest version of nextcloud is already 16. A lot of new features are missing.


#3

I have a similar issue. Running UCS in a Hyper-V VM installed from .iso, all is fine with AD domain join and Nextcloud. As soon as I add OnlyOffice the VM gets borked. OnlyOffice install never fully completes, and I get weird errors like “could not connect to module service” the VM itself shows just a black screen, and I can access the portal but only sometimes. It usually ends up in some kinda useless state with 10GB ram in use and no CPU in use.

I have tried this also using the pre-made VM for Virtualbox and converting to Hyper-V. But result is the same.

I have however installed from the exact same .iso on an old Dell Poweredge with 4GB ram and it works perfectly with AD member integration, Nextcloud and OnlyOffice. So I can only conclude that something is broken when running OnlyOffice in a VM with UCS.