Problem mit UCS Versionsupdate (2.0-0 auf 2.0-2)

german

#1

Beim Update meines UCS-Servers (von 2.0-0-4 auf 2.0-2) aktualisere ich die Apt-Quellen auf

[code]deb http://apt.univention.de/2.0/maintained/ 2.0-2/all/
deb http://apt.univention.de/2.0/maintained/ 2.0-2/i386/

deb http://apt.univention.de/2.0/unmaintained/ 2.0-2/all/
deb http://apt.univention.de/2.0/unmaintained/ 2.0-2/i386/
deb http://apt.univention.de/2.0/unmaintained/ 2.0-2/extern/
[/code]
Beim Upgrade mit apt-get dist-upgrade bekam ich dann die Fehlermeldung:[code]
Multiple Choices
The document name you requested (/2.0/maintained/2.0-0-ucs2.0-2/i386/ldap-utils_2.3.30-6.21.200805271449_i386.deb) could not be found on this server. However, we found documents with names similar to the one you requested.

Available documents:

* /2.0/maintained/2.0-0/i386/ldap-utils_2.3.30-6.21.200805271449_i386.deb (common basename)
* /2.0/maintained/2.0-1/i386/ldap-utils_2.3.30-6.21.200805271449_i386.deb (common basename)
* /2.0/maintained/2.0-2/i386/ldap-utils_2.3.30-6.21.200805271449_i386.deb (common basename)[/code]

Bei der Suche nach einer Lösung stellte ich fest, dass die Paketdateien in /var/lib/apt/lists/*_Packages
einen falschen Dateipfad enthielten: 2.0-0-ucs2.0-2/ statt 2.0-2/.

Gibt es da ein generelles Problem mit dem Update? Ich habe als Workaround die Dateipfade in den Package-Dateien korrigiert.


#2

Hallo,

Vielen Dank für den Hinweis. Hier waren die Pfade in den Paketindex-Dateien falsch. Der Pfad ist nun angepasst.

Generell zum Update einer UCS Installation: Dies sollte immer über Univention Updater durchgeführt werden und nicht über die die Online-Repositorys. Im Supportfall werden nur Systeme unterstützt, die mit Univention Updater aktualisiert worden sind, da nur dieser Weg ausführlich getestet wird.

Mit freundlichen Grüßen
Andreas Büsching