Problem:Configured a wrong oxImapServer for mail domain


If you configured a wrong oxImapServer for your mail domain.


Workaround from this Bug
Bug 48432

> Actual example for the workaround:
> context id: 10 (default)
> context admin user: oxadmin (default)
> context admin user password: univention
> mail domain: ucs.local
> new imap server: mail.ucs.local
Please use the secrets file:

for u in $(/opt/open-xchange/sbin/listuser -c 10 -A oxadmin -P "$(</etc/ox-secrets/context10.secret)" | grep 'ucs.local' | awk '{print $1}'); do 
  /opt/open-xchange/sbin/changeuser \
    -c 10 -A oxadmin \
    -P "$(</etc/ox-secrets/context10.secret)" \
    -i "$u" --imapserver 'mail.ucs.local'

The "grep 'ucs.local'" has to be adjusted, to it matches only to the wrong entries: e.g. "grep ''"

And to change the setting in the UDM:

udm oxmail/oxdomain list

Copy the dn you want to modify and then:

udm oxmail/oxdomain modify --dn,cn=domain,cn=mail,dc=hub,dc=foo,dc=bar --set