Problem: Can not Add Users "kopanoMrProcess: attribute type undefined"

Problem:

When adding users through UMC you are getting the following error and the user does not get created:
kopano

When using a template for Kopano users the user creation works fine.
Trying to add the user through udm results in the same error on the command line.

Environment

The Kopano app is installed on a non-master server and your environment has only limited access to the Internet for security reasons.

Solution

Comparing dpkg -l| grep kopano on the master and the kopano server showed a version mismatch.

Solution

Step 1

Allow the master host to access at least update.software-univention.de through http/ https (Port 80 and 443)

Step 2

Re-install master packages. No error should occur.
univention-app install --only-master-packages kopano-core=8.7.0-1
This might produce an error or still not work. Ignore it for the moment and proceed with step 3 if it still fails.

Step 3

Install the full base package and remove it afterwards:

univention-app install kopano-core
univention-app remove kopano-core

Step 4

Compare the packet versions between the master and the kopano server. They should be equal now. User creation should work as expected.