Printer Share not working properly, if at all

cups
printing
printer

#1

Hi,

I have a printer (HP ENVY 5530) connected wirelessly to the network, and a Print/File Server connected to the same network, that I want to use to share the printer to some windows computers.

Printer address is 192.168.1.16
Server address is 192.168.1.30

I have attempted many times to utilise UCS print service to share the printer on the network and most attempts have failed (Windows cannot find printer) or in some cases the printer share is found and printer installed, but nothing (not even a test page will print), in this case the file /var/log/cups/access_log shows 'Print-Job successful-ok" but again, nothing was printed. However this file also shows many entries ending with "CUPS-Add-Modify-Printer client-error-not-possible), example:

localhost - FileServer$ [10/Jan/2018:00:02:39 +0800] “POST /admin/ HTTP/1.1” 200 278 CUPS-Add-Modify-Printer client-error-not-possible
localhost - - [10/Jan/2018:00:03:04 +0800] “POST /printers/f30printer HTTP/1.1” 200 294266 Print-Job successful-ok

I know this printer works because I have tested it directly from windows machines.

I have been trying for hours to get this printer to work from my Print Server and have done much research online to resolve this issue but to no avail, I have exhausted all my options and now I am asking here, if anyone can please help me find out what is wrong with my configuration and get my printer working, I would greatly appreciate it.


#2

update:

after running hp-setup for my printer and configuring the share like so:

protocol:ipp
destination:FILESERVER/printers/ENVY_5530

where ENVY_5530 is the name of the printer as installed by hp-setup.

This configuration worked, and I could access the printer from a windows computer and install, and it even printed a test page.

however after printing the first test page from windows 8, it will not print anything else, from any device.


#3

Hey,

getting printers, especially consumer-grade devices, to play nice with CUPS is often an exercise in futility. As no one else has responded so far, I doubt you’ll receive an answer that’ll solve your particular problem. As printing directly from Windows to the printer works I suggest you think about using a Windows machine as the print server for this particular printer — or you simply install it directly on all machines which need to print on it. Using group policies may help here.

Kind regards,
mosu


#4

Hey,

Thanks for the reply.

As I said, I managed to get it to print once, but it stopped after that, I think it may have stopped because the printer has no black and color ink left in their cartridges, and I think I remember reading somewhere that CUPS in UCS will stop a printer if the printer reports a problem (so maybe no ink will stop the printer from printing jobs from the server?), or something along those lines. I am really hoping to use UCS (because I dont have access to spare windows systems, and I also have Mac systems in my network) so I can use the Quota system (keep track of who does how much printing). I have since re-installed my entire network, with fresh installs of UCS, so before I set up the printer again, I will get some new cartridges and put them in, hopefully that will alleviate the issue, otherwise I will have to think of something else.

Thanks again for the reply!

Kind Regards,

Adam


#5

Hey,

yeah OK, the quota stuff makes sense. If you give it a go again, remember that you can always access CUPS directly via https://server.domain.tld:631 (log in as administrator when asked). You can check the printer status there and reactivate it if it is currently stopped.

Kind regards,
mosu


#6

I just tried ‘https://server.domain.tld:631’ and i get the error message ‘Site cannot be reached’. Any thoughts on what I might be doing wrong?

Kind Regards,

Adam


#7

Did you actually replace server.domain.tld with the name & domain of your server?


#8

Yes I did replace them, I just omitted them for the post.


#9

Got it, after checking the cupsd.conf file, the ServerAlias entry didnt contain the ‘.tld’ part of the address, so I can access cups now using ‘https://server.domain:631