Prevent local Mail Delivery | Kopano, postfix, fetchmail, ciphermail

I followed a tutorial and can successfully encrypt my mails via Ciphermail Gateway.

Postfix sends the mails out, fetchmail collects them from DomainFactory.
Installed is: , DomainController, Fetchmail, KVM, virsh-mananger and Kopano, Ciphermail Gateway is running as a virtual machine.

So far everything works fine, but I would like to disable the local delivery of Postfix itself.

Example:
My domain is the test de.
But I want Postfix to send out all mails via my smarthost and not try to deliver mails to peter@test.de or Sascha@test.de directly locally.
The mailboxes simply do not exist on the server, but they do exist at my provider.

I already tried to comment out ’ relaydomains, and mydestination’ etc. in the ‘main.cf’ but that did not work.

Postfix wants to deliver locally when it detects the domain.
How can I prevent this? I ALWAYS want to send via my smarthost.

Thanks for your help in advance.