PostgreSQL 8.4 -> 9.1 Migration schlägt fehl

german

#1

Hallo

bin nach dem Artikel sdb.univention.de/1292 vorgegangen um die SQL database zu migrieren.

leider scheint UCS bei der DB Migration nicht die alte DB zu finden. und damit auch nicht migrieren zu können.

hat jemand Tipps für mich?

danke
Gerd

root@mail:~# chmod -x /usr/sbin/univention-pkgdb-scan
root@mail:~# service postgresql stop
[ ok ] Stopping PostgreSQL 8.4 database server: main.

root@mail:~# rm -rf /etc/postgresql/9.1
root@mail:~# apt-get install --reinstall postgresql-9.1
Reading package lists… Done
Building dependency tree
Reading state information… Done
Suggested packages:
oidentd ident-server locales-all
The following NEW packages will be installed:
postgresql-9.1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 3275 kB of archives.
After this operation, 17.0 MB of additional disk space will be used.
Get:1 updates.software-univention.de/4.0/maintained/ 4.0-4/amd64/ postgresql-9.1 9.1.16-0.9.201509171755 [3275 kB]
Fetched 3275 kB in 1s (1823 kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
Selecting previously unselected package postgresql-9.1.
(Reading database … 121825 files and directories currently installed.)
Unpacking postgresql-9.1 (from …/postgresql-9.1_9.1.16-0.9.201509171755_amd64.deb) …
Setting up postgresql-9.1 (9.1.16-0.9.201509171755) …
Error: The locale requested by the environment is invalid.
Error: could not create default cluster. Please create it manually with

pg_createcluster 9.1 main --start

or a similar command (see ‘man pg_createcluster’).
update-alternatives: using /usr/share/postgresql/9.1/man/man1/postmaster.1.gz to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto mode
root@mail:~# pg_dropcluster 9.1 main --stop
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
Error: specified cluster does not exist
root@mail:~# service postgresql start
[ ok ] Starting PostgreSQL 8.4 database server: main.
root@mail:~# pg_upgradecluster 8.4 main
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
Stopping old cluster…
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
Disabling connections to the old cluster during upgrade…
Restarting old cluster with restricted connections…
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “de_DE.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
Error: The locale requested by the environment is invalid.
Error: Could not create target cluster


#2

Hallo,

beim flüchtigen Querlesen fallen mit zunächst die Perl-Warnungen auf.
Da die Thomas Krenn AG mittlerweile Univention-Partner ist, wird sicher niemand böse sein, wenn mal auf deren Wiki mit einem Eintrag zu Hintergrundinformationen verlinke.
Perl warning Setting locale failed unter Debian.
Ich denke, man sollte entweder die passende locale auf dem UCS installieren (geht in der UMC) oder wie beschrieben die SSH Client Option deaktivieren.

Und wenn selbst das nicht hilft die Postgres-Problematik hier zu lösen ist zumindest die Warnung weg und wir können das Wesentliche sehen.

Viele Grüße,
Dirk Ahrnke


#3

danke! Der Link auf das Krenn Wiki war gut. Nachdem ich die locale settings ergänzt habe hat es dann funktioniert!