Postfix smtpd permit_sasl_authenticated status=0

mail
german

#1

Hallo,
ich habe Kopano in einem UCS Slave-Server (4.1.4) installiert.
U.a. soll mail von externen Benutzern über Thunderbird versandt werden.
Postfix/main.cf enthält:
smtpd_recipient_restrictions = permit_mynetworks,
permit_sasl_authenticated,
reject_unauth_destination,
reject_unlisted_recipient
Beim Versand von einer externen Adresse bekomme ich jedoch einen Relay-Fehler.
Das mail.log zeigt:
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: generic_checks: name=permit_mynetworks status=0
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: generic_checks: name=permit_sasl_authenticated
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: generic_checks: name=permit_sasl_authenticated status=0
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: generic_checks: name=reject_unauth_destination
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: reject_unauth_destination: p.pridt@chello.at
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: permit_auth_destination: p.pridt@chello.at
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: ctable_locate: leave existing entry key p.pridt@chello.at
Feb 5 19:51:14 mailserver postfix/smtpd[19069]: NOQUEUE: reject: RCPT from 80-108-124-215.cable.dynamic.surfer.at[80.108.124.215]: 554 5.7.1 p.pridt@chello.at: Relay access denied; from=paul@pridt.at to=p.pridt@chello.at proto=ESMTP helo=<[192.168.235.122]>

Der Versand funktioniert, wenn ich die externe Adresse in mynetworks eintrage.
testsaslauthd funktioniert.
root@mailserver:~# testsaslauthd -u xxx -p xx
0: OK “Success.”

Die obigen Meldungen deuten darauf hin, das die sasl-authentication durch Postfix nicht funktioniert:
Hat schon jemand dieses Problem gehabt, bzw. gibt es eine Lösung?
mfg Paul


#2

Hallo p.pridt,

mir scheint es, die Einstellung sollte für ‘smtpd_relay_restrictions’ anstatt für ‘smtpd_recipient_restrictions’ vorgenommen werden.

vgl. Postconf - smtpd_recipient_restrictions, Postconf - smtpd_relay_restrictions

Gruß Nico


#3

Hallo,

über welchen Port wird versendet? “smtpd_sasl_auth_enable” (in master.cf) ist standardmäßig nur für 465 und 587 gesetzt.

Viele Grüße,
Dirk Ahrnke


#4

Hallo,
vielen Dank, das war’s. Der Versand über Port 587 funktionert
Paul