Phpmyadmin installieren

german

#1

Hi,

weiß jemand, ob es möglich ist phpmyadmin in UCS zu installieren?
wenn ja wäre es schön wenn mir jemand erklären kann wie ich es hinbekomme. da ich gern eine datenbank auf meinem Server speichern möchte.
habe auch ein programm auf meinem windows pc welches mit einer datenbank verknüpft ist. nun möchte ich das dass Programm die Datenbank auf meinem Server abruft.

mfg blackra1n85 :slight_smile:


#2

Ja ist es:

ucr set repository/online/unmaintained='yes'
univention-install phpmyadmin
ucr set repository/online/unmaintained='no'

#3

danke für die schnelle Antwort. ich habe es so durchgeführt aber nun gibt es probleme. habe den server neugestartet und nun bekomme ich die meldung: "Give root password for maintenance (or type Control-D to Continue):

hier geht jetzt nichts mehr.

mfg br85


#4

Moin,

das Problem mit dem »give your password…« scheinen mehrere Leute zu haben. Als Workaround können Sie versuchen, wie dort im Posting beschrieben sich einmal einzuloggen und dann Strg+D zu drücken. Wenn danach der Server normal bootet, dann ist gut.

Falls mit der PHPMyAdmin-Installation soweit alles klappt, so lassen Sie uns diesen Thread hier bitte schließen und die Boot-Probleme in dem bereits verlinkten Thread weiter behandeln. Das ist übersichtlicher.

Gruß,
mosu


#5

Das wird wohl nichts mit phpmyadmin zu tun haben. Mit dem Problem bist du nicht ganz alleine.


#6

also ich hoffe es, das es nichts mit der installation von phpmyadmin zu tun hat.
vorher lief alles einwandfrei.aber ich konnte mich als root anmelden mir ist das pw wieder eingefallen.

mfg


#7

Habe phpmyadmin erfolgreich installiert. Wie kann ich es jetzt nutzen?


#8

Moin,

mal hostname-des-servers/phpmyadmin/ probiert?

Gruß,
mosu


#9

Hallo,

gerne würde ich diese Diskussion noch einmal aufgreifen. Um phpMyAdmin zu installieren habe ich wie vorgeschlagen aus dem unmaintained-Repository die Software installiert, was auch ohne Fehlermeldung stattfand.

Ein Aufruf über den erwartbaren Serverpfad (hostname-des-servers/phpmyadmin/ oder ähnlich) ist jedoch nicht möglich “out of the box”. Welche zusätzlichen Schritte müssen auf UCS durchgeführt werden, damit der Zugriff möglich wird?

Danke und schöne Grüße!


#10

Moin,

wenn Sie während der Installation den Apache2 nicht ausgewählt haben, so reicht es eigentlich, die Konfigurationsdatei »/etc/phpmyadmin/apache.conf« nach »/etc/apache2/conf.d« zu verlinken und anschließend den Webserverprozess neu laden zu lassen:

ln -sf /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf apache2ctl reload

Anschließend sollte der Zugriff auf »https://servername/phpmyadmin/« klappen. Bei mir tut’s das auf jeden Fall.

Gruß,
mosu


#11

Danke, nun funktioniert es mit dem Pfad SERVER/phpmyadmin

Das Kommando für den Neustart des Apache-Servers musste ich wandeln in “apache2ctl -k restart”.

Schöne Grüße


#12

Erledigt, habs gefunden. Danke!

Hallo,

myPHPAdmin läuft. Nur welchen Account und welches Password muss ich denn nutzen?


#13

Sie melden Sich an phpMyAdmin mit den Logindaten an, mit denen Sie sich auch direkt am MySQL anmelden.

Unter Univention ist der MySQL-Superuser-Account root. Das dazugehörige Passwort wird bei der Installation des Pakets univention-mysql automatisch erzeugt und steht in der Datei /etc/mysql.secret.

Gruß,
mosu


#14

Hallo!

Ich habe Univention 4.2-0 errata25 und phpmyadmin installiert. Leider funktioniert der Aufruf hostname/phpmyadmin nicht …
Ich habe auch die Verlinkung
ln -sf /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf
probiert, sie funktioniert aber nicht, da es conf.d und phpmyadmin.conf nicht gibt …

Mit welcher Datei soll ich die linke Datei verlinken? - Bei mir gibts es folgende Dateien/Verzeichnisse im apache2:
apache2.conf conf-enabled magic mods-enabled ports.conf.debian sites-enabled
conf-available envvars mods-available ports.conf sites-available ucs-sites.conf.d

VG, Achim.


#15

Das Verzeichnis sollte eigentlich angelegt werden - ist es ggf. möglich den phpmyadmin noch einmal neu zu installieren? Alternativ (Gefrickel [tm]) das Directory ggf. einmal manuell erstellen und die Konfigdatei ebenfalls erstellen und den Inhalt aus der apache.conf einfügen. Danach “ln -sf …”


#16

hat bei mir geklappt - allein ist der Pfad der Apache Conf in einer UCS 4.2 Installation anders:

/etc/apache2/ucs-sites.conf.d

also: ln -sf /etc/phpmyadmin/apache.conf /etc/apache2/ucs-sites.conf.d/phpmyadmin.conf

dann geht es.