PHP7 für moodle

php

#1

Hallo,
die Cool Solution für die Installation von Moodle auf ucs bezieht sich leider noch auf eine ältere moodle-Variante.
https://wiki.univention.de/index.php/Cool_Solution_-_Install_Moodle_and_setup_ldap_authentication

Die aktuelle Variante von Moodle (3.4 Stand Feb 2018) benötigt jedoch PHP7.

Unter Debian 8.7 (Jessie) lässt sich PHP7 installieren. Dazu gibt es zahlreiche Anleitungen im Netz. Alle empfehlen die Deinstallation von PHP5.6. Dabei werden aber zahlreiche Univention-Pakete mit deinstalliert. Daher habe ich das nicht durchgeführt.

Kann man UCS 4.2 auch mit PHP7 betreiben? Wird PHP7 von UCS 4.3 unterstützt?

Danke
Holger Jessen-Thiesen


#2

UCS 4.3 basiert auf Debian Stretch welches PHP 7 mitbringt.

Viele Grüße von der bytemine GmbH


#3

Das klingt nach einem klassischen Anwendungsfall für Docker. Docker ist auf Univention bereits vorinstalliert und eine kurze Suche liefert einige fertige Images.


#4

Dann werde ich wohl abwarten. Das Per-Release ist ja schon raus. Danke