OX App Suite uninstall/install problems

After upgrade to UCS 4.7.7 on a Mail domain server (slave) I got problems with OX App Suite. So I decided to try to uninstall and install OX App Suite again.

After uninstall and restart there are no OX apps installed, but there are OX objects in Domain Master: OX Mail and OX Resources. IMAP connectivity is still available to the mailbox and users can connect but server does not receive messages and does not send. The error while sending is like “Server error: 451 4.3.0 : Temporary lookup failure”. I changed Postfix’s virtual table UCR variables as described here https://forge.univention.org/bugzilla/show_bug.cgi?id=45083 (I set default values) and I can start send and receive again.

So, the first question is: how can I completely remove OX App Suite and have back a default (working) mail server?

Second question: I also tried to install OX App Suite again, but the procedure stopped here

22511 packages                         20-12-08 09:47:05 [    INFO]: Configurazione di open-xchange-admin (7.10.4-7)...
 22511 packages                         20-12-08 09:47:05 [    INFO]: ox_exists_property: /opt/open-xchange/etc/ModuleAccessDefinitions.properties does not exist
 22511 packages                         20-12-08 09:47:05 [    INFO]: dpkg: errore nell'elaborare il pacchetto open-xchange-admin (--configure):
 22511 packages                         20-12-08 09:47:05 [    INFO]:  il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1

and OX App Suite can’t be installed anymore.

Any advice on how to install again OX App Suite and eventually on how to completely remove the App in case of necessity?

Thanks.

Hello I was having the same issue. I solved it by doing the following:
Install OX Suite
ssh into the host that has ox suite installed

touch /opt/open-xchange/etc/ModuleAccessDefinitions.properties
dpkg --configure -a