OX App Suite nachträglich installiert: Vorhande Benutzer können E-Mail nicht aufrufen

open-xchange
german

#1

Hallo allerseits.

Ich habe nachträglich Mailserver und die OX App Suite auf einem Slave-Server installiert. Dieser war frisch aufgesetzt. Es handelt sich beim System um UCS 4.3, aktueller Patchstand.

Im Nachgang habe ich in der Benutzerverwaltung unter “Konto” die App Suite für die vorhandenen Benutzer aktiviert.

Melden sie sich nun an der App Suite an dauert dies ewig und sie bekommen die Meldung, dass keine Verbindung zum Mailserver möglich sei.

Eine Verbindung in das Postfach per Thunderbird funktioniert reibungslos. Testweise habe ich OX für einen Benutzer wieder gelöscht und neu angelegt. Dabei konnte ich im Thunderbird beobachten, dass die Ordnerstruktur entfernt und wieder angelegt wurde.

Wenn ich Benutzer frisch anlege, haben diese keine Probleme. OX meldet sofort an und das Postfach ist sofort sichtbar.

Ich habe in der auth.log des Slave, auf dem Dovecot und OX App Suite installiert sind, folgende Meldung für die alten Benutzer bei der Anmeldung an der App-Suite:

`Feb  1 18:43:48 ox PAM-univentionmailcyrus[17319]: continuing as user firstname.lastname
Feb  1 18:43:48 ox auth[17319]: pam_ldap: error trying to bind as user "uid=firstname.lastname,cn=users,dc=intern,dc=example,dc=com" (Invalid credentials)
Feb  1 18:43:48 ox PAM-univentionmailcyrus[17321]: continuing as user firstname.lastname
Feb  1 18:43:48 ox auth[17321]: pam_ldap: error trying to bind as user "uid=firstname.lastname,cn=users,dc=intern,dc=example,dc=com" (Invalid credentials)
Feb  1 18:43:48 ox PAM-univentionmailcyrus[17322]: continuing as user firstname.lastname
Feb  1 18:43:48 ox auth[17322]: pam_ldap: error trying to bind as user "uid=firstname.lastname,cn=users,dc=intern,dc=example,dc=com" (Invalid credentials)
Feb  1 18:44:03 ox auth[17319]: pam_krb5(dovecot:auth): authentication failure; logname=firstname.lastname uid=0 euid=0 tty=dovecot ruser=firstname.lastname@intern.example.de rhost=192.168.001.100
Feb  1 18:44:03 ox auth[17321]: pam_krb5(dovecot:auth): authentication failure; logname=firstname.lastname uid=0 euid=0 tty=dovecot ruser=firstname.lastname@intern.example.de rhost=192.168.001.100
Feb  1 18:44:03 ox auth[17322]: pam_krb5(dovecot:auth): authentication failure; logname=firstname.lastname uid=0 euid=0 tty=dovecot ruser=firstname.lastname@intern.example.de rhost=192.168.001.100
`

Ich weiß, dass OX die Nutzerdaten nach MySQL kopiert. An die komme ich leider nicht dran. Eine Änderung des Passworts in der Nutzerverwaltung - in der Hoffnung, dass der Nutzer aktualisiert wird - brachte leider auch nichts.

Vielleicht kann ja jemand behilflich sein.

Mit besten Grüßen
Daniel


#2

Hello,

for our international users a translation of the question:

Subject: OX App Suite installed later: Existing users cannot access e-mail

Hello, everybody.

I installed mail server and the OX App Suite on a slave server afterwards. This was freshly installed. The system is UCS 4.3, current patch status.

Subsequently, I activated the App Suite for the existing users in the user administration under “Account”.

If you log on to the App Suite this takes forever and you get the message that no connection to the mail server is possible.

A connection to the mailbox via Thunderbird works smoothly. For testing purposes I deleted OX for one user and created a new one. I noticed in Thunderbird that the folder structure was removed and recreated.

When I create new users, they don’t have any problems. OX logs in immediately and the mailbox is immediately visible.

In the auth.log of the slave where Dovecot and OX App Suite are installed, I have the following message for the old users when logging in to the App Suite:

Feb  1 18:43:48 ox PAM-univentionmailcyrus[17319]: continuing as user firstname.lastname
Feb  1 18:43:48 ox auth[17319]: pam_ldap: error trying to bind as user "uid=firstname.lastname,cn=users,dc=intern,dc=example,dc=com" (Invalid credentials)
Feb  1 18:43:48 ox PAM-univentionmailcyrus[17321]: continuing as user firstname.lastname
Feb  1 18:43:48 ox auth[17321]: pam_ldap: error trying to bind as user "uid=firstname.lastname,cn=users,dc=intern,dc=example,dc=com" (Invalid credentials)
Feb  1 18:43:48 ox PAM-univentionmailcyrus[17322]: continuing as user firstname.lastname
Feb  1 18:43:48 ox auth[17322]: pam_ldap: error trying to bind as user "uid=firstname.lastname,cn=users,dc=intern,dc=example,dc=com" (Invalid credentials)
Feb  1 18:44:03 ox auth[17319]: pam_krb5(dovecot:auth): authentication failure; logname=firstname.lastname uid=0 euid=0 tty=dovecot ruser=firstname.lastname@intern.example.de rhost=192.168.001.100
Feb  1 18:44:03 ox auth[17321]: pam_krb5(dovecot:auth): authentication failure; logname=firstname.lastname uid=0 euid=0 tty=dovecot ruser=firstname.lastname@intern.example.de rhost=192.168.001.100
Feb  1 18:44:03 ox auth[17322]: pam_krb5(dovecot:auth): authentication failure; logname=firstname.lastname uid=0 euid=0 tty=dovecot ruser=firstname.lastname@intern.example.de rhost=192.168.001.100

I know that OX copies the user data to MySQL. Unfortunately I can’t reach them. Changing the password in the user administration - in the hope that the user will be updated - didn’t help either.

Maybe someone can help.

Best regards
Daniel


#3

@gulden:
Thanksfor the translation. I should have written in english in at first; I guess that reaches a bigger audience :slight_smile:

@all:
Thanks to those who thougt about the problem, but it seems to be solved by the today’s update for the ox app suite. Seems, there were some issues with the join scripts which are eliminated now.

Thanks and bye for now
Daniel