Owncloud - Zarafa verbinden mit Files

german

#1

Hallo Leute,

wie verbinde ich nun Owncloud mit Zarafa? Ich bekomme immer die Meldung falsche IP.

Siehe Bild:



#2

Hallo,

ich habs gerade mal ausprobiert. Beim Aktivieren musste ich allerdings die WebApp neu laden. Aus unserem ownCloud-Server haben wir auĂźerdem ein offizielles SSL-Zertifikat, ob das mit der normalen UCS-CA geht, kann ich im Moment nicht sagen.

Viele GrĂĽĂźe,
Dirk Ahrnke



#3

funktioniert leider nicht. Habe die Einstellungen 1 zu 1 ĂĽbernommen.

Wir haben ein selbstsigniertes Zertifikat.


#4

Hallo,

auf dem ownCloud-Server sollte man zumindest im Access-Log vom Apache sehen, ob die WebApp bis dorthin kommt.
Falls Sie in ownCloud nicht den Force auf https gesetzt haben und wie im Beispiel zu sehen, der ownCloud intern ist, könnte man mal versuchen, ohne SSL zu verbinden.
Es wäre zumindest auch mal zu prüfen, ob denn der WebDAV-Zugriff (ihrowncloud.domain.tld/owncloud … hp/webdav/ ) überhaupt mit einem DAV-fähigen Client funktioniert.

Viele GrĂĽĂźe,
Dirk Ahrnke


#5

ja webdav und die cloud funktionieren soweit.

Files funktioniert mit 443 und mit Port 80 nicht. Wir haben als Startseite nicht mail.test.de sondern mail.test.de/webapp, kann das Probleme verursachen?
Ich habe im Files Plugin auf Port 80 umgestellt und trotzdem will er per 443 verbinden. Habe in Owncloud https erzwingen deaktiviert.

Anbei das Log aus Access:

::1 - - [01/Oct/2015:07:38:58 +0200] "OPTIONS * HTTP/1.0" 200 130 "-" "Apache/2.2.22 (Univention) (internal dummy connection)"
::1 - - [01/Oct/2015:07:38:59 +0200] "OPTIONS * HTTP/1.0" 200 130 "-" "Apache/2.2.22 (Univention) (internal dummy connection)"
192.168.15.53 - maier [01/Oct/2015:07:39:00 +0200] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1503 "-" "Mozilla/5.0 (Windows) mirall/2.0.1"
::1 - - [01/Oct/2015:07:39:06 +0200] "OPTIONS * HTTP/1.0" 200 130 "-" "Apache/2.2.22 (Univention) (internal dummy connection)"
192.168.15.11 - maier [01/Oct/2015:07:39:13 +0200] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1503 "-" "Mozilla/5.0 (Windows) mirall/2.0.1"
192.168.15.11 - maier [01/Oct/2015:07:39:15 +0200] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 6950 "-" "Mozilla/5.0 (Windows) mirall/2.0.1"
192.168.15.53 - - [01/Oct/2015:07:39:27 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 768 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - maier [01/Oct/2015:07:39:32 +0200] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1503 "-" "Mozilla/5.0 (Windows) mirall/2.0.1"
192.168.15.11 - maier [01/Oct/2015:07:39:45 +0200] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 7100 "-" "Mozilla/5.0 (Windows) mirall/2.0.1"
192.168.15.11 - maier [01/Oct/2015:07:39:45 +0200] "PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1" 207 1353 "-" "Mozilla/5.0 (Windows) mirall/2.0.1"
192.168.15.53 - - [01/Oct/2015:07:39:49 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 1077 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:49 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 943 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:49 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 2797 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:50 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 572 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:50 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 572 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:57 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 768 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:58 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 686 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:58 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 717 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"
192.168.15.53 - - [01/Oct/2015:07:39:58 +0200] "POST /webapp/zarafa.php?sessionid=p19r6vdvh3o4hkvqfv87aml575&subsystem=webapp_1443677907528 HTTP/1.1" 200 686 "https://mail.test.de/webapp/index.php" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0"

#6

ich hab es nun doch kurz selber getestet, also mit der Startseite von webapp hat es auch nichts zu tun.

Wir bekommen immer folgenden Fehler:

Die IP Adresse ist 100% richtig, habe auch schon localhost oder name probiert. Immer der selbe Fehler.


#7

Ich habe nun das Problem gefunden…es ist wirklich das Zertifikat !!! Das nächste mal trinke ich erst meinen zweiten Kaffee aus :slight_smile:

Ich hatte im File Plugin NUR den Port geändert und vergessen das da noch ein haken mit “https” ist. Schaltet man bei Owncloud force https und filesplugin https aus funktioniert es.

Wir werden heute ein amtliches Zertifikat kaufen, dann teste ich es nochmals.


#8

Hallo,

zu Testzwecken könnte auch erstmal ein kostenloses Zertifikat reichen, z.B. StartSSL.
Ansonsten ist es bestimmt auch möglich, die UCS-CA als vertrauenswürdig für die WebApp-Komponenten zu importieren.

Viele GrĂĽĂźe,
Dirk Ahrnke


#9

Wir haben nun ein “richtiges” Zertifikat und dort klappt es auf anhieb. Mit einem Selbssignierten muss man also wirklich noch etwas umstellen !!!


#10

Der Ursprung des Fehlers liegt in meinen Augen in der Tat im selbstsignierten Zertifikat. Da das Zertifikat nicht validiert werden kann, baut das Files Plugin (imho zu recht) keine Verbindung auf. Ohne vertrauenswürdiges Zertifikat könnte sich das Plugin andernsfalls halt sonstwohin verbinden.

Der einfach Test hierbei ist: kann man über die Kommandozeile vom System auf der die WebApp läuft z.B. mit Curl eine Verbindung zum Zielsystem aufbauen (curl localhost/index.html). Wenn dieses Kommando durchläuft, dann klappt es auch mit dem Files Plugin.


#11

wenn man es nun weiĂź es ist kein Problem, die Fehlermeldung wrong IP verwirrt ein wenig. Habe bestimmt 2-3 Stunden nach dem Fehler gesucht :slight_smile:


#12

[quote=“fbartels”]Der Ursprung des Fehlers liegt in meinen Augen in der Tat im selbstsignierten Zertifikat. Da das Zertifikat nicht validiert werden kann, baut das Files Plugin (imho zu recht) keine Verbindung auf. Ohne vertrauenswürdiges Zertifikat könnte sich das Plugin andernsfalls halt sonstwohin verbinden.

Der einfach Test hierbei ist: kann man über die Kommandozeile vom System auf der die WebApp läuft z.B. mit Curl eine Verbindung zum Zielsystem aufbauen (curl localhost/index.html). Wenn dieses Kommando durchläuft, dann klappt es auch mit dem Files Plugin.[/quote]

Mir will nicht in den Kopf, wieso wir damit leben wollen oder sollen, dass die UCS-CA, deren Ursprung sehr wohl bekannt und nachvollziehbar ist, weniger vertrauenswürdig sein soll als der vorinstallierte Kram mit Comodo, Digicert und vielleicht sogar “Honest Achmed’s Used Cars and Certificates”. Wenn Z-Files Systembibliotheken benutzt, sollte es doch möglich sein, diese so zu konfigurieren, dass sie der lokalen CA vertrauen.


Kopano Files -> Nextcloud
#13

Evtl. hilft das hier?
-> [bug]39179[/bug]


#14

[quote=“Grandjean”]Evtl. hilft das hier?
-> [bug]39179[/bug][/quote]

Danke, genau den hatte ich gesucht.