Owncloud: Version Mix Up

owncloud

#1

Hi,

Some weeks ago i have upgrade to owncloud version 9.1.1-migration as descripted in this youtube video: https://www.youtube.com/watch?v=C_OyqDIpf5s

Afterwards the AppCenter showed me, that there is an additional upgrade available to 9.1.4. Installing in failed without any detailed error message.

So i tried to upgrade via command line, but did a mistake. Instead of executing an upgrade with the version number i have execute a univention-app install owncloud82=9.1.4-20170330. This failed and has uninstalled owncloud.
i have then tried to install the same version again, but then i got a SSL Handshake error. So i unstalled that again.

Then i installed the 9.1.1-migration version again, which was successful. The problem is only that the owncloud user for ldap access (uid=owncloudsystemuser,cn=sysusers,cn=owncloud,dc=intranet,dc=tobiaslorentz,dc=de) does not exist and the ldap attributes for activate owncloud and configure quote per user is not visible.

I now executed the update with univention-app upgrade owncloud82 again from command line and that installed successful. The AppCenter says now that 9.1.4-20170330 is installed, but owncloud itselfs says that it is on 9.1.1.
LDAP attributes on the user are still missing.

I have also checked what docker images are actually running, as it might be that now both versions are installed:

root@ucs:~# docker ps
CONTAINER ID        IMAGE                                                  COMMAND                CREATED             STATUS              PORTS                                           NAMES
a17a4fc1ff50        docker.software-univention.de/ucs-appbox-amd64:4.1-3   "/sbin/init"           23 hours ago        Up 23 hours         0.0.0.0:40005->80/tcp, 0.0.0.0:40006->443/tcp   jovial_newton       
cf3ac153920f        docker.software-univention.de/ucs-appbox-amd64:4.1-3   "/sbin/init"           2 weeks ago         Up 25 hours         0.0.0.0:40003->80/tcp, 0.0.0.0:40004->443/tcp   sharp_bell          
b42003bd7aae        docker.software-univention.de/nextcloud:11.0.2-0       "/bin/sh -c /usr/sbi   4 weeks ago         Up 25 hours         0.0.0.0:40002->80/tcp                           drunk_einstein      
84912067fa1e        docker.software-univention.de/ucs-appbox-amd64:4.1-3   "/sbin/init"           3 months ago        Up 25 hours         0.0.0.0:40000->80/tcp, 0.0.0.0:40001->443/tcp   insane_yonath

I think something got really messed up. Would be great if someone could help.

Kind Regards,

Tobias Lorentz


#2

Hi,

ah, so there is a video, thats how another user ended up in a similar situation… No one should use that video to upgrade a production system, things will break, it’s only for testing and the information is outdated.

The video note states that this upgrade path is still in Beta status and actively worked on. It is therefore unclear which test version from the test app center was run when you tried to update.

I would strongly suggest that you go back to a backup if available. If thats not possible, i would try the following, completely untested and unverified steps, after creating a backup or snapshot:

  • uninstall the current owncloud app version
  • Switch back to the production app center with univention-app dev-use-test-appcenter --revert, you may have to install univention-appcenter-dev
  • Install the productive owncloud app version (should be 9.1.1) and debug further from there.

#3

The update from ownCloud 8.2 to ownCloud 9.1 is now available:


#4

Hi,

I tried to install owncloud again via UMC and that failed without an error message. So I logged in via ssh and have done a univention-app list and found there two owncloud entries:

owncloud
  Name: ownCloud
  Latest version: 10.0.1-20170523
  Installations: 

owncloud82
  Name: ownCloud 9.1
  Latest version: 9.1.1-20170120
  Installations:

I have tried to install owncloud82, but that failed with the following error:

owncloud82=9.1.1-20170120 already has its database
Registering schema /usr/share/univention-appcenter/apps/owncloud82/owncloud82.schema
WARNING: Registered package version 9.1.4-20170330 is newer, refusing registration.
A newer version of /usr/share/univention-appcenter/apps/owncloud82/owncloud82.schema has already been registered. Skipping...
Registering the container host owncl-62868227 for owncloud82
Module: zarafa-cfg
Module: kopano-cfg
Verifying Docker registry manifest for app image docker.software-univention.de/ucs-appbox-amd64:4.1-3
[Errno 1] _ssl.c:504: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Aborting...
Going to remove ownCloud 9.1 (9.1.1-20170120)

My currently installed owncloud version does not appear in the appcenter (means the app center says there is no owncloud installed). It seems also not to use docker as docker ps returns the following

root@ucs:/tmp# docker ps
CONTAINER ID        IMAGE                                                  COMMAND                CREATED             STATUS              PORTS                                           NAMES
82d28c413e9d        nextcloud/univention-app-image:11.0.3-0                "/bin/sh -c /usr/sbi   5 weeks ago         Up 2 weeks          0.0.0.0:40002->80/tcp                           high_brattain       
84912067fa1e        docker.software-univention.de/ucs-appbox-amd64:4.1-3   "/sbin/init"           6 months ago        Up 2 weeks          0.0.0.0:40000->80/tcp, 0.0.0.0:40001->443/tcp   insane_yonath

When i execute a docker inspect on this second container, i find somewhere the following path mapping:

    "Volumes": {
        "/var/lib/univention-appcenter/apps/dudle/conf": "/var/lib/univention-appcenter/apps/dudle/conf",
        "/var/lib/univention-appcenter/apps/dudle/data": "/var/lib/univention-appcenter/apps/dudle/data"
    },

So this seems to be just the doodle and not the owncloud. So owncloud seems to still run locally.
Within the owncloud frontend it shows its version as ownCloud 9.0.6 (stable)

How should i proceed to upgrade to a current version?

Kind Regards,

Tobias Lorentz


#5

This looks like a proxy is intefering with the connection to our docker repository. Can you temporarily bypass it in the next try?

I do not have a system with your exact state, so the steps i describe below may not fit a 100% for you. Make a backup or snapshot before proceeding.

It seems the owncloud 9.0.6 app is not correctly registered. To move forward, you should follow the migration guide loosely. Instead of removing the app with univention-app remove ..., the owncloud packages on the host should be uninstalled with univention-remove. It is also important that you install the correct App version
owncloud82=9.1.4-20170427.


#6

Hi damrose,

thank you very much for your hints. i did it as described and everything run smooth, but i have several problems:
First the owncloud segement in the user configuration is missing.
Then the owncloudsystemuser was not created.

First i was able to log in via owncloudadmin. With all other I got an internal server error.
I have seen that the LDAP connection has not worked. I tried to exchange the bind-dn from uid=owncloudsystemuser,cn=sysusers,cn=owncloud,dc=intranet,dc=tobiaslorentz,dc=de to my Administrator account, but that didn’t had an impact.
So i restarted the server to see if this might fix it.
Now i cannot log in into any account, instead i am getting the message

Zugriff verboten CSRF check failed

I logged onto the docker instance via univention-app shell owncloud82 and re-joined the domain, just to make sure that is is properly joined, but without any effect.

The configuration of the owncloud inside docker is the following:

owncloud/db/name: owncloud
owncloud/directory/data: /var/lib/owncloud
owncloud/group/enableDomainUsers: 1
owncloud/group/enabled: 0
owncloud/join/groups/filter: 
owncloud/join/users/filter: (&(|(&(objectClass=posixAccount)(objectClass=shadowAccount))(objectClass=univentionMail)(objectClass=sambaSamAccount)(objectClass=simpleSecurityObject)(&(objectClass=person)(objectClass=organizationalPerson)(objectClass=inetOrgPerson)))(!(uidNumber=0))(!(|(uid=*$)(uid=owncloudsystemuser)(uid=join-backup)(uid=join-slave)))(!(objectClass=ownCloudUser)))
owncloud/join/users/update: yes
owncloud/ldap/UUIDAttribute: 
owncloud/ldap/base/groups: 
owncloud/ldap/base/users: 
owncloud/ldap/cacheTTL: 600
owncloud/ldap/disableMainServer: 0
owncloud/ldap/displayName: displayName
owncloud/ldap/group/displayName: cn
owncloud/ldap/group/searchAttributes: cn,description,mailPrimaryAddress
owncloud/ldap/groupFilter: (&(objectClass=posixGroup)(ownCloudEnabled=1))
owncloud/ldap/groupMemberAssoc: uniqueMember
owncloud/ldap/internalNameAttribute: uid
owncloud/ldap/loginFilter: (&(|(&(objectClass=posixAccount)(objectClass=shadowAccount))(objectClass=univentionMail)(objectClass=sambaSamAccount)(objectClass=simpleSecurityObject)(&(objectClass=person)(objectClass=organizationalPerson)(objectClass=inetOrgPerson)))(!(uidNumber=0))(!(uid=*$))(&(uid=%uid)(ownCloudEnabled=1)))
owncloud/ldap/tls: 1
owncloud/ldap/user/homeAttribute: uid
owncloud/ldap/user/quotaAttribute: ownCloudQuota
owncloud/ldap/user/searchAttributes: uid,givenName,sn,description,employeeNumber,mailPrimaryAddress,displayName
owncloud/ldap/userlistFilter: (&(|(&(objectClass=posixAccount)(objectClass=shadowAccount))(objectClass=univentionMail)(objectClass=sambaSamAccount)(objectClass=simpleSecurityObject)(&(objectClass=person)(objectClass=organizationalPerson)(objectClass=inetOrgPerson)))(!(uidNumber=0))(!(uid=*$))(&(ownCloudEnabled=1)))
owncloud/user/enabled: 1
owncloud/user/quota: 1000000000

Thank you very much for your help!

Kind Regards,

Tobias Lorentz


#7

Hi,

in the meanwhile the CSRF check failed has disappeared again. But still the LDAP connection isn’t working.

Kind Regards,

Tobias Lorentz


#8

Hi,

another update, now i was able to establish the ldap connection by using the Administrator account. But it is still strange why the owncloud user hasn’t got created and the schema isn’t there. I found in another thread to check the ldap.conf, but that returns correctly the following:

root@ucs:~# grep owncloud /etc/ldap/slapd.conf
include         /var/lib/univention-ldap/local-schema/owncloud82.schema

Kind Regards,

Tobi


#9

The app installation seems to be incomplete, the owncloudsystemuser definitely has to be created. If you have a backup or snapshot i would try to reinstall the docker app. I think you have to manually drop the owncloud database after removing the app, before reinstalling, though.