Owncloud - Lost connection to LDAP-Server

german

#1

Hallo,

und ein weiteres (wahrscheinlich Anfänger-)Problem:
Ich schaffe es irgendwie nicht Owncloud so zu konfigurieren, dass ein anderer Nutzer als der owncloudadmin zugreifen kann. Jedes Mal wenn ich im Adminkonto versuche die Nutzer zu konfigurieren kommt die Fehlermeldung “Lost Connection to LDAP-Server”. Meine aktuelle Konfiguration ist im Anhang zu sehen. Der Fehler tritt sowohl beim Zugriff innerhalb des eigenen Netzes als auch aus dem WWW auf.

Hat jemand eine Idee, was ich falsch mache???

Gruß
Marc









#2

Hallo,

die Screenshots sehen nicht nach der ownCloud-Integration aus dem App Center aus, oder?
Eine manuelle Installation sollte natürlich auch gehen, allerdings müsste man dann LDAP über LDAP ansprechen. Im Screenshot zur Serverkonfiguration steht aber HTTPS. Das wird so nicht funktionieren.

Viele Grüße,
Dirk Ahrnke


#3

Owncloud wurde aus dem AppCenter heraus installiert. Der Zugriff aus dem WWW war aber so nicht möglich. Ich habe dann in der config.php meine MyFritz Adresse als trusted Domain ergänzt. Dann konnte ich mich ich von außen als Administrator einloggen. Ab da versuche ich dieses LDAP Konfigurationsproblem zu lösen.

Gibt es irgendwo eine Anleitung, wie die AppCenter Integration korrekt durchgeführt werden muss?


#4

Hallo,

zur Lösung des “trusted Domain” Problems ist der Eintrag des externen Hostnamens in der config.php ausreichend.

Im Normalfall besteht kein Anlass, an der LDAP-Grundkonfiguration etwas zu ändern. Eine Ausnahme wäre der Betrieb von ownCloud in einer Umgebung mit mehreren LDAP-Servern oder eine Neuinstallation der App.
Im letzteren Fall beachten Sie bitte zunächst die Hinweise in Owncloud 8 - kein Login möglich.

Unter Umständen könnte es reichen, den “2. Server” (siehe Screenshot) zu entfernen, das Kennwort des owncloudsystemuser aus /etc/owncloudsystemuser.secret auszulesen und dieses sowohl im UCS als auch in der ownCloud-LDAP-Konfiguration einzutragen.

Viele Grüße,
Dirk Ahrnke


#5

Danke für die Hinweise.

Nach Deinstallation, folgen der Hinweise aus dem genannten thread und Neuinstallation scheine ich einen Schritt weiter zu sein.

Aber… Es gibt dann ein neues Problem: Was ist denn der Nutzername des Admins der MYSQL/MariaDB???

Die Datei mysql.secret habe ich gefunden und ausgelesen. Aber was ich auch versuche… Folgende Fehlermeldung:



#6

Hallo,

dieser Installationsversuch war nicht erfolgreich. Details sollten in /var/log/univention/management-console-module-appcenter.log, im join.log oder in /var/log/apt/*.log stehen.

Die Datenbankeinrichtung übernimmt die Installationsroutine. Sie geht allerdings derzeit davon aus, dass keine Reste vergangener Installationen vorhanden sind. Im verlinkten Thread hatten wir einen einfachen Fall. Wenn aber zum Beispiel noch eine andere auf MySQL setzende Applikation installiert ist, wird natürlich das MySQL-Paket nicht deinstalliert und die ownCloud-DB bleibt erhalten. Man müsste in diesem Fall wahrscheinlich die DB mit MySQL-Mitteln löschen.

Viele Grüße,
Dirk Ahrnke