Owncloud Invalid license key


I had my free ownCloud instance up and running in a VirtualBox, but unfortunatelly I had to reinstall my virtual machine from scratch using the UCS 5.0 with owncloud bundle I downloaded to perform my first installation.

After some attempts I finally could complete the installation, but when I try to access I get the “Invalid license key” message in the login page (as shown in the screenshot below).


Reading in the internet, I found it has been solved for other users by following these steps:

“Go to your Univention srv > App Center > Owncloud > Manage Instalation > App Settings > Delete OwnCloud enterprise license key > Apply changes > Restart App”

I’ve tried this same process (screeshot below) but I still have the same message.


I’ve also read another option could be entering directly to the MariaDB, but I’m not able to execute anything related with this:


Can you please help me?

Best regards


The occ command you used only works in the path, where occ is stored.
The correct call is:

univention-app shell owncloud sudo -u www-data php /var/www/html/occ <command>

The root password for mysql can be found in /etc/mysql.secret
To enter the MariaDB database execute

mysql -u root -p`tail /etc/mysql.secret`

WARNING! You should exactly know, what to do in mysql. Otherwise you might crash the whole database.
Take a snapshot of your VM, before you start!

Hi! First of all, thank you very much for your help!!

I’ve tried to execute the steps you shared but without any results:


I’m not experienced at all in Linux so any step to be executed in this environment is not easy at all for me. Is there any GUI way to proceed?

Best regards


You did use the character ’ instead of ` in your “tail”- command.
On US keyboard left of the “1” but not on “”" key left of < Enter >.

Hi, as I’m using an Spanish keyboard, I wasn’t able to get this character but instead, I’ve connected with Putty and I’m able to paste the command you’ve shared.

The bad point is I’m not able to follow the steps I’ve found in the Internet concerning the deletion of the enterprise_key in the MariaDB. Is there any walkthrough that could be followed to remove the “enterprise key” or any other hints I could follow?

Best regards


Hi Miguel,

I know this won’t exactly be a solution for the ownCloud problem, but have you considered nextcloud?

There’s far more functionality and apps, plus the recent sale of ownCloud might slow community contributions.

I should probably add that nextcloud is also in UCS app store in one of the latest iterations.

Hi! I installed NextCloud as you suggested and it’s functional now. Thanks for the hint