Owncloud in subdomain

german

#1

Hi,

ich habe für Owncloud eine Subdomain eingerichtet, aber ein LDAP-Login auf der Weboberfläche ist nur via srv/owncloud/ erfolgreich.
Mit der Subdomain owncloud.srv/ übergibt owncloud an die App ein leeres Usernamen-Feld, soweit lässt sich das im Log verfolgen.

Außerdem funktioniert in der Konstellation auch das Abfragen der Kalender und Kontakte in der Variante /principals/ nicht, was die meisten Apps und auch Apple zum Anzeigen aller Kalender und Adressbücher verwenden. Auch hier: nehme ich die Variante Unterverzeichnis, rennt es wie von selbst.

Hat jemand ne Idee oder einen Konfigurationstipp, wie ich Owncloud und die LDAP-App da zu erfolgreicher Zusammenarbeit bringe?

PS.: die Host-Konfiguration hat auf dem alten Server ohne LDAP wunderbar funktioniert, am Apachen liegt es im Zweifel eher weniger, außer er wäre bei UCS besonders gepatcht.

Gruß,

Roman Dilken


Owncloud mit eigener Domain
#2

Hallo,

habe den Fehler wohl selbst gefunden. In der config.php muss die Option overwritewebroot auskommentiert werden.

Gruß,

Roman


#3

Hallo,

[quote=“dilkenro”]In der config.php muss die Option overwritewebroot auskommentiert werden.
[/quote]

Das scheint zumindest der richtige Weg zu sein. Ich würde es aber wahrscheinlich nicht auskommentieren, sondern wie in der Doku (Config.php Parameters) leer oder mit"/" setzen.
Im Moment wüsste ich zwar keine Routine, die diese Option bei einem Update setzt, aber man weiß nie, was vom Upstream kommt. Da gab es immer mal Überraschungen.

Viele Grüße,
Dirk Ahrnke


#4

Da ich noch die parallele Anfrage in der Mailingliste gesehen habe, musste ich doch wirklich noch mal nachsehen/nachfragen, warum overwritewebroot gesetzt ist.
Deshalb noch eine kleine Richtigstellung.
Wir haben irgendwann aus Performancegründen den Cronmodus auf System gestellt. Dabei wird die cron.php gerufen, was wiederum nur zuverlässig funktioniert (funktionierte?), wenn overwritewebroot gesetzt ist.
Das Ganze passiert im Join-Skript und wenn ich den Code richtig verstanden habe, auch nur, wenn der Backgroundmode nicht gesetzt ist. (Also im Umkehrschluß nicht, wenn man bewusst einen anderen Cron-Modus gesetzt hat).
Was man alllerdings prüfen sollte, wäre, ob bei gelöschter oder geänderter “overwritewebroot” Option, der eingestellte Cronmodus noch funktioniert.

Viele Grüße,
Dirk Ahrnke