Owncloud 8 zu 8.1 Update?

german

#1

Hallo Leute,

ich habe heute im App Store gesehen das es Owncloud 8.1 als Extra Punkt zum installieren gibt. Wie seht es nun aus wenn man von 8 auf 8.1 Updaten möchte? Kann ich das alte deinstallieren und neue installieren OHNE Datenverlust? Oder wie mache ich nun ein Update?

danke


#2

Sollte so wie immer ohne Datenverlust gehen. Ein Backup ist aber natürlich nie verkehrt.


#3

Bitte auch Update von ownCloud 8.0 auf 8.1.3: beide Apps “installiert” beachten.

In der nächsten Version wird es zudem folgende Ergänzung in der im App Center direkt angezeigten Readme geben:


#4

Danke für die Info. Habe das Update Fehlerfrei durchgeführt. Es funktioniert alles ohne Probleme und ich habe nun endlich die neuste Owncloud Version :slight_smile:


#5

Hallo, mir ist nun doch etwas aufgefallen. Es funktioniert zwar alles einwandfrei, aber ich habe den Typischen 8.1 Owncloud Fehler:

Es wurde kein PHP Memory Cache konfiguriert. Konfiguriere zur Erhöhung der Leistungsfähigkeit, soweit verfügbar, einen Memory Cache. Weitere Informationen finden Sie in unserer Dokumentation.
Der „Strict-Transport-Security“-HTTP-Header ist nicht auf mindestens „15768000“ Sekunden eingestellt. Für umfassende Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in unseren Sicherheitshinweisen erläutert ist.

Ich habe das auf anderen “normalen” Debian oder Ubuntu Servern schon öfters repariert. Aber wie sieht das nun bei dem UCS Server aus?


#6

Zu den Konfigurationswarnungen hatte ich etwas in ownCloud 8.0.8 -> 8.1.3 geschrieben.
Für HSTS dürfte es demnächst ein Erratum geben.


#7

ich habe das Paket nachinstalliert, kein Fehler. Den Apache neu gestartet, aber der Eintrag in der Owncloud Config fehlt.

‘memcache.local’ => ‘\OC\Memcache\APC’;

Setze ich den Eintrag Manuell (vor Trusted Domains) habe ich eine weise Seite.


#8

Sollte das Semikolon am Zeilenende nicht besser ein Komma sein?
Soweit ich gesehen habe, wird der memcache nur automatisch gesetzt, wenn bei der Installation von ownCloud das php-apc-Paket schon vorhanden ist. Das passiert aber außerhalb unserer Integration, deshalb müsste ich erst suchen, wo.


#9

das mit dem Komma war der Fehler :slight_smile: Sorry nun funktioniert es. Diese Fehlermeldung ist nun weg.