Openvpn


#1

I have installed OpenVPN, but I am unable to download and access the ready2go packages for any user I allow vpn access.


#2

Hello yesman1232,

your post does not provide much information to react upon. Can you please provide more details on your current experience and what ‘… I am unable to download and access…’ actually means?

Which version of UCS and OpenVPN4UCS is in use? Are multiple servers involved (f.e. a dedicated member server for OpenVPN)?

Which steps do you take to gain access and which (unmatched) results do you expect by doing so?

Has the server been configured properly before you tried to provide user access?

Please crosscheck the provided instructions as well. They can be found here:

English: bytemine.net/files/openvpn4ucs_howto_en.pdf

German: bytemine.net/files/openvpn4ucs_howto_de.pdf

Did you know these?

Regards,

Ingo von Thielau


#3

As in when I go to my UCS server home page and click on “OpenVPN4UCS - ready2go packages”. I type in my username (for an account that is authorized to access openvpn), then type in my username and password in the popup box, I am given “openvpn-email-username.zip” but when I click on this I am presented with a “Forbidden: you don’t have permission to access /readytogo/username/openvpn-email0username.zip on this server.”


#4

Hello yesman1232,

can you please check if the users have posix accounts or just use ‘simple authentication’? This would be good to know.

In the current dev version is a small change, which affects the access rights to the ready2go packages. It is possible that this is related and maybe has already been taken care of.

Looking forward to your reply.

Regards,

Ingo von Thielau


#5

Posix was enabled (I actually cannot disable), but Simple authentication account was not, I enabled Simple authentication and was still was not able to download “openvpn-email-username.zip” for the account I have enabled


#6

Hello yesman1232,

thanks for checking your settings. Activating (in this case adding) ‘simple authentication’ has no effect here. The important part for me was if posix is in use for the user(s).

So far it looks like the access rights to package are not set correctly. Why is hard to tell at this point. Regenerating them could solve this already, as the privileges are set during the process.

Please try to disable the vpn access for the user / save and re-enable the vpn access for the user / save again. These steps will delete the ready2go package and generate a new one.

Regards,

Ingo von Thielau


#7

Bytemin,

Unfortunately this did not work, I’m going to try to go into the server itself and change the permissions manually.