OpenProject install (still) broken?


Some time ago I was already struggling with similar issues… [OpenProject install/usage fatal errors] (OpenProject install/usage fatal errors)
and now, when trying to “update” (fresh install actually) to the last OpenProject the problems are still here…

So, I firstly upgraded the UCS system from 4.2-3 to 4.3-2 (this also did not went smoothly) and then tried to install a fresh OpenProject 8.0.0…
No go - the installation was aborted very soon with the error: “cannot start docker container” - the reason? missing CMD/ENTRYPOINT executable. The installation tries to start the container with /sbin/init but there IS NO SUCH FILE in the image??!!

After a few retries I abandoned this and tried with the previous version - 7.3.1 - again problems!
This time it “installed stuff” quite some time but at the end the installation was aborted… something regarded to dialog and openproject package??

Is this “normal” or am I the only one with such problems with “things which should be extremely easy and user friendly”???


OK… after further digging and experimenting… I’m slowly giving up…

The docker image(s) for openproject 8.0.0 is practically “empty”… all the univention tools are missing (ucr…) basically an “empty container”… which is also 1/5th of the size of “older relases”:   4.3-2               b92d93b1a6ec        6 days ago          110 MB <--- base for open project!!        4.1-4               d1eace19938d        12 months ago       507 MB

nextcloud/univention-app-image                        11.0.3-0            f67dc9ece2f3        17 months ago       611 MB               11.0.2-0            e8e2d43742e9        18 months ago       588 MB

will post the status/errors with v 7.3.1 of openproject install…

I’m not at all familiar with open project, but:

was the version 8 installed from the test appcenter? apps that are there are most of the time still in development, which could explain why its not working.

most likely as the production app center only shows version 7.3.1 while version 8.0.0 is in appcenter-test.

Tottaly forgot to check for the app center repository… (it was quite a while ago when I firstly installed OP and other stuff)…
The “system repository” shown in the web gui I checked… but forgot about this one buried in the ucr settings… and the in package name did not ring a bell… :shame:

I’l re-try with the “official” repo…

@ahrnke: do you know what is the version of ucs in docker image for OP 7.3.1? Is it still at 4.1?

Other than user/app (inst/uninst) integration of OpenProject with UCS… is there any other “big benefit” of the “ucs packaged” OpenProject app?
Especially as OP (and some others) app “blocks” the UCS systems (major) updates/upgrades.

Thinking of manually update/upgrade (and maintain) OpenProject in the docker container to keep up with the newer versions…as official AppStore version(s) tend to be “a little behind”.

Anyone sees some obvious problems/issues with such “approach”?

Kind regards,

it looks like that, OpenProject only appears in the 4.1 tree of the repository of the Appcenter, but as it is dockerized it is installable on later UCS versions.
Given that there is something in the Test-Appcenter dated September 2018 I’d think that the maintainer is working on an upgrade.

I am not familiar with OpenProject at all but as we have worked on several integrations for UCS I know about the problems keeping these apps up to date. At the end it is all a question of resources (people, time, money).

For our own environment as well as for customers we are currently running a mixed approach, using apps from the Appcenter as well as standard installations with loose integration (LDAP and so on). Some applications are too limited regarding their integration depth and flexibility but this isnt always a strong requirement.

Hello @mculibrk

OpenProject 8.0.0 is currently under development for the App Center. I suggest, you wait for it.

If you still have the Test App Center activated, please deactivate it and install the latest production version of OpenProject.

What are the benefits of the app vs. the default OpenProject packages offered by the vendor? It is the integration with the identity management of UCS. As soon as you create a new user, provide a primary mail address and activate it for OpenProject, this user can login or other users can already assign work packages.

There are plans to switch to the official docker image provided by OpenProject after the version 8.0.0 has been released. My hope is that the current glitches disappear and updates are released much closer to the upstream releases.

Best regards,

After quite a lot of pulled hair I managed to make it work. Somewhat…

I upgraded (with quite some issues) the docker image to 4.2-something and then “upgraded” the OpenProject app with the officially distributed .deb packages.
Strangely, this part went through quite “normally” (giving all the other problems I had).

Anyway… after the upgrade to 8.0.1 was actually completed I hit another annoying issue - constantly getting error 422 - CSRF errors (Cross Site Request Forgery)… a nice/new option which is enforced by default from version 7.4.5 onwards, apparently…
After a lot (really lot!) of digging, trial and error… somehow I made it “work”…
Had to drop the DB and let the OpenProject re-create the database and forcing RAILS_FORCE_SSL=true in configuration options… (even if all the ssl is handled by Apache on the UCS “frontend” and all the containers/services work in http only mode…
I’m not very “aware” of all the Rails/OpenProject “under the hood” stuff but obviously there is also something “wrong” in the database as the thing just would not run with the original DB…

Now I’m struggling with the user “auto creation/population” as the OP user table is empty (besides admin)…
I hoped the univention-directory-listener would re-create the users but it do not do that “by default”…

I’m now testing/searching for new surprises to start jumping out…