Open-scsi autologon

isci

#1

I’ve installed open-iscsi on my server,
I can discover the NAS, login works fine with:
iscsiadm -m node --targetname “iqn.MYNAS:cloud-test” --portal “192.168.1.98:3260” --login
I create a label, and increate a mount point in /etc/fstab.
mount -a works without any issue.

The node.startup settings from /etc/iscsi/iscsid.conf file, are also changed to automatic

But When I reboot my device, the boot failed, and I need remove the settings from /etc/fstab.

I’ve no idea what I do wrong? or which step I missed to log-on the iscsi automaticly.


#2

Good day goudduif,

does your system freeze at bootsplash?
If it does, then, then you have to edit the boot options for the UCS system within GRUB. You can disable the splashscreen and raise the loglevel so as to see what happens when the system freezes. You can do that in the following steps:

  1. Press button “e” in GRUB bootloader

  2. Find the following line:

     linux ... /vmlinuz-... ... ro quiet loglevel=0 rootdelay=5 splash
    
  3. Edit the line: Remove quiet and change slpash to nosplash - also set loglevel to 5
    the line should now look like this:

     linux ... /vmlinuz-... ... ro loglevel=5 nosplash
    
  4. Boot by pressing F10

These changes are temporal and are re-set at next boot. You can make that change permanent by booting into the working UCS system, logging in as root, and setting the following UCR variables:

ucr set grub/bootsplash=nosplash grub/quiet=no grub/loglevel=5

The default text console only has 80 columns and 25 rows, so some important output might scroll of. The error you get can help you further resolve the problem. You can send the error message or make a photo, so that we can can give some
hints.

Regards

Anna Takang