"Offline" Installation of 4.2 Update

ucs-4-2

#1

Hi,

i just wanted to install the 4.2 Update and the system told me that i should shutdown my virtual machines (UVMM).
Unfortunately, my router / firewall (Sophos UTM) are running as a VM inside Univention.
When i shut them down, then the UCS does not has anymore an internet connection.

Is there the possibility to first download all all files for the download, then shutdown the VMs and install the update more or the less “Offline”?

Thank you very much for your help!

Kind Regards,

Tobias Lorentz


#2

Hi,

you can use the update DVD for offline use, it contains the required packages. With UCS 4.2 the ISO image is rather large, because we updated the debian base packages. Information on how to use the update DVD can be found in the manual.

If you are using UVMM also make sure to read and understand the implications for QEMU in the UCS 4.2 release notes, in particular http://sdb.univention.de/1384


#3

Hi,

i tried now to do the upgrade, but i wasn’t successful. Based on the Docu i understood that i first need to create a local repository. So i downloaded the UCS_4.1-4-amd64.iso as well as UCS_Update_4.1-4_-_4.2-0-amd64.is.

I created then the repository by executing univention-repository-create --iso=UCS_4.1-4-amd64.iso
It returned that it was created but something with version 0 is not supported and i should upgrade.
So i executed univention-repository-update net while still having my router on the VM running.

Then i have shutted down the VM and having the no internet anymore.
Then i started the upgrade:

root@ucs:/tmp# univention-upgrade --iso=UCS_Update_4.1-4_-_4.2-0-amd64.iso

Starting univention-upgrade. Current UCS version is 4.1-4 errata444

Checking for local repository:                          found

Update the local repository via network [Y|n]? n

Update the local repository via cdrom [Y|n]? n

Checking for package updates:                           none
Checking for app updates:                               found

The following apps can be upgraded:

Dudle: The underlying container can be upgraded

Starting app upgrade
Do you want to upgrade Dudle [Y|n]? n

done
Checking for release updates:                          The connection to the repository server failed: Configuration error: Network is unreachable. Please check the repository configuration and the network connection.

I also tried it with --updateto=4.2-0, but with the same result. The same when answering the second question with yes.

What am i doing wrong?

Kind Regards,

Tobi


#4

/Nevermind the previous post, it was not correct.

Things I encountered while updating: The term “local repository”, as it is used by Univention, refers to “repository on the local network”. As mostly stated in the manual, you perform an offline update alias from the local network by the following steps:

  • setup a “local” repository with univention-repository-create and some installation media. This also sets up the univention configuration registry and copies all packages to/var/lib/univention-repository/mirror
  • update that repository with univention-repository-update from network or DVD
  • make sure, that the repository is reachable via http and that the path /univention-repository/ exists on the webserver.
  • Fiddle with the variable apache2/force_https, as apt expected an unencrypted connection in my case
  • run univention-upgrade

@tobiaslorentz Maybe the error you are encountering is a problem with the availability of the repository on your local network. Are you able to connect to the (local) server or get a directory listing with something like wget http://youserver/univention-repository/? If no, you should check your Apache 2 configuration.