O365 Connector: Updating User Information is not working

office-365

#1

Hi to everyone,
i have the issue, that the office 365 connector plugin tries to update some user contact information from ucs to o365 and fails.
Here is some output of my log.

> 18.05.17 16:28:23.118  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:143  office 365 user listener active
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:164  listener observing attributes: ['displayName', 'employeeType', 'givenName', 'l', 'mail', 'mailAlternativeAddress', 'mailPrimaryAddress', 'mobile', 'postalCode', 'roomNumber', 'sn', 'st', 'street', 'telephoneNumber']
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:165  listener is also observing: ['krb5KDCFlags', 'krb5PasswordEnd', 'krb5ValidEnd', 'passwordexpiry', 'sambaAcctFlags', 'sambaKickoffTime', 'shadowExpire', 'shadowLastChange', 'shadowMax', 'univentionOffice365Enabled', 'userPassword', 'userexpiry']
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:166  attributes mapping UCS->AAD: {'telephoneNumber': 'telephoneNumber', 'employeeType': 'jobTitle', 'mailPrimaryAddress': 'otherMails', 'mobile': 'mobile', 'roomNumber': 'physicalDeliveryOfficeName', 'l': 'city', 'st': 'usageLocation', 'mailAlternativeAddress': 'otherMails', 'street': 'streetAddress', 'sn': 'surname', 'postalCode': 'postalCode', 'mail': 'otherMails', 'givenName': 'givenName', 'displayName': 'displayName'}
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:167  attributes to sync anonymized: []
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:168  attributes to never sync: []
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:169  attributes to statically set in AAD: {}
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:170  attributes to sync: ['displayName', 'employeeType', 'givenName', 'l', 'mail', 'mailAlternativeAddress', 'mailPrimaryAddress', 'mobile', 'postalCode', 'roomNumber', 'sn', 'st', 'street', 'telephoneNumber']
> 18.05.17 16:28:23.120  LISTENER    ( ERROR   ) : o365(I): office365-user.<module>:171  attributes to sync from multiple sources: {'otherMails': ['mailPrimaryAddress', 'mailAlternativeAddress', 'mail']}

So the problem is, i have not configured/installed this connector on my own and therefore i perhaps have bit less information about how this works or where i have to look. Perhaps you have an idea what i have to check, to identify the problem.

Thanks a lot :slight_smile:


#2

Hello manti,

you seem to have enabled the UCR variable office365/debug/werror.
That makes log messages of all levels will be written as errors (ERROR) and with debug information to the logfile. This is used for debugging only.

In the above log there is no error. The original log level is INFO, indicated by the (I) in o365(I).


#3

Thanks for your fast answer!
yes thats true, i was changing the debug level before to 4 in case to get more useful information, but the logs in /var/log/univention/management-console-module-office365.log were still empty. At the beginning i started with this error in the log, before i was changing the loglevel zu 4: (I’m hiding some information with “xxxx”)

18.05.17 15:53:48.906  LISTENER    ( ERROR   ) : o365(D): office365-user.handler:262  new is enabled.
18.05.17 15:53:48.906  LISTENER    ( ERROR   ) : o365(D): office365-user.handler:316  old_enabled and new_enabled -> MODIFY (uid=xxx,cn=xxxx,dc=xxx,dc=xxx)
18.05.17 15:53:48.906  LISTENER    ( ERROR   ) : o365(D): listener.modify_user:186  modifications=['street', 'st']
18.05.17 15:53:48.916  LISTENER    ( ERROR   ) : o365(D): listener.modify_user:188  udm_attrs={'street': 'xxxx-Stra\xc3\x9fe 1', 'st': 'DE'}
18.05.17 15:53:48.925  LISTENER    ( ERROR   ) : o365(I): azure_handler._modify_objects:329  Modifying user with object_id 'xxxx-xxxx-xxx-xxxx-6c75e1e4492c' and modifications {'streetAddress': 'xxxx-Stra\xc3\x9fe 1', 'usageLocation': 'DE'}...

So does it mean that there is still no error?
Perhaps another question: what time is normal to sync informations from ucs to office 365?


#4

Changes made to objects (like users and groups) in LDAP are synced by a listener module (see http://docs.software-univention.de/manual-4.2.html#introduction:Listener_notifier_replication and http://docs.software-univention.de/manual-4.2.html#domain:listenernotifier).
The listener modules log to /var/log/univention/listener.log. Usually they start a few seconds after the change was made, depending on the system load.
You have still not written what the problem exactly is. What attribute of a user do you change, and is not getting syncd to Office 365?
Please post the output of: ucr search ^office365


#5

Sorry for my late answer.
To your question: the problem was a changed AD attribute “Title”. I changed the value in univention and it was not syncing it to o365 for a day.
After I tried it a few days later, the problem didn’t appear. Perhaps there was an issue with o365. I also tried to update some attributes today and the sync was nearly instantly.
Thanks for your help (and the links).