Nur 100Mbit mit tg3 NIC Treiber

hardware
german

#1

Wir setzten den UCS 1.3 auf einem “HP Proliant DL 360 G4” ein.
Die Netzwerkkarte ist vom Typ Broadcom 7782 (BCM5704).
Der UCS lädt automatisch und fehlerlos das tg3 Modul.
Allerdings erreichen wir trotz Gigabit Karte und Gigabit Switch nur 100Mbit.

Unter SLES9 läuft die Karte mit tg3 problemlos mit 1000Mbit.
Auch wenn statt tg3 das Modul bcm5700 von Broadcom geladen wird, läuft die Karte mit 1000Mbit.
Die Module werden mit Auto-Negotiation geladen.

Muss man evtl. die Karte hart auf 1000Mbit setzen? Oder sollte der Treiber ausgetauscht werden?

Gruss,
Frank Müller


#2

Hallo,

können Sie einmal die Ausgabe vonmii-tool -vposten? mii-tool befindet sich im Paket net-tools.

Mit freundlichen Grüßen,

Wolf Wiegand


#3
mii-tool -v
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:08:18, model 25 rev 0
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
eth1: no link
  product info: vendor 00:08:18, model 25 rev 0
  basic mode:   autonegotiation enabled
  basic status: no link
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

#4

Hallo,

mii-tool arbeitet nicht immer zuverlässig, wir haben deshalb auf download.univention.de/download/addons/ucs1.3-0/ das Paket ethtool_2-1.1.200601261118_i386.deb abgelegt. Damit lässt sich mit ethtool -s ethX speed 1000die gewünschte Geschwindigkeit einstellen. Die momentan verwendete Geschwindigkeit lässt sich mit dmesg | grep ethXoder mit ethtool ethX(X=Nummer des Netzwerkinterfaces) anzeigen.

Mit freundlichen Grüßen,

Wolf Wiegand