No such object


#1

Hello!

Sorry, I was not able to insert images directly to the message.

I faced with one issue and I need help with it.

I’ve created several containers and user templates for several departments.
When I am trying to create a new account specifying container for user and its template I am receiving following message:
http://screencloud.net/v/lG2U

And UCS web GUI offers me to make some changes of user’s account in Advanced mode.
After I looked at settings I found such error
http://screencloud.net/v/iP7O

I’ve changed this field by selecting simply the value “None” repeatedly. Clicked “Save” and I got next error message:
http://screencloud.net/v/nY8T

But If I look at list of accounts in container, I will find that account has been created.

What can be the reason of such issue and how can we resolve it?

Thanks in advance.


#2

Hey,

I’ve tried to reproduce your problem(s). I’ve run into the issue that the password locking isn’t set properly for some reason in the past, but as you’ve found out yourself that is easy to circumvent.

The other issue (“the username is already in use”) is a bit tricky, it seems. I’ve been successful in triggering it exactly once, but I haven’t been able to reproduce it afterwards – no matter what I tried. I’m therefore thinking this is a corner case that’s not handled properly by the backend. When you create a new user the UMC creates a temporary user object, sets it up properly, and only after everything has been done it moves that temporary object to its final location. If such a temporary object is left in the tree this error message may be triggered.

That one time I did trigger the error (“the username is already in use”) I could click “save” a second time, and that time the user object was saved successfully. I therefore recommend you try that, too, if it happens again.


#3

Hi,

Thanks for your reply.

But I get error message about “No such object” every time when I create account for user in specific container by user template.
How can I fix this behavior? Maybe this is because of some mistake in template?

The same situation with other errors. I see them every time when I create new account in specific container.
If I create user in default container, I mean /users, then all is good and UMC creates user without any issues.
I use UCS 4.1-0 errata44. And I remember that some releases ago I was not getting these error messages.

Can I somehow check that UCS works correctly? I’ve already tried System Diagnostic tool and it found nothing.


#4

On my UCS creating users with custom templates in custom containers works just fine. I’ve just verified this by creating new containers and new templates, then creating a couple of users with said templates in said contains. No error messages whatsoever.

Please verify that the custom containers are flagged to be used for users (LDAP Directory → navigate to your custom container → right-click on the container in the tree, select “edit” → “advanced settings” → expand the “container settings” and make sure “add to standard users containers” is checked).

I cannot re-create a situation in which “no such object” occurs all the time or where “the username already exists” or something similar appears.

Also keep in mind that user and group names must be unique across the whole LDAP directory, not only within the same container.


#5

Hello,

Thanks for advices.
All my special containers are flagged to be used for users. And I always remember that user and group names must be unique.

So I’ve created same structure at test UCS server as on production and made a dozen of tests. All was fine.
Then I decided to recreate user templates at production UCS4 and make tests again. I’ve just re-created template for clients, checked it and all was fine.
I’ve checked other templates and they were fine too. I tried to reproduce issue by changing settings of templates but I couldn’t.
All is working now as it should.

Looks like there were some mistakes in user templates or maybe in LDAP database which disappeared after recreating user template.

Whatever, thanks a lot for your help.


#6

It does indeed sound like a broken template – however that happened… You’re welcome.