No more meetings after changing the subdomain

Hi@all,

This is a test environment only. Not really important. I still describe it because it could be a bug of Jitsi as Docker container on UCS5. The environment:

Role: UCS 5.0.1 Node.
FQHN: gw01.intern.lan
IP: 192.168.83.6

The scenario / test is exclusively local. Without external access. After installing Jitsi (without customization) it is under:

https://jitsi.gw01.intern.lan

accessible. Local users can start or participate in meetings. Now I try the URL using VHOST on:

https://meet.intern.lan

to change it. As it is described here:

Since this is an internal test, I am using the self-signed UCS certificates.

nano /etc/apache2/sites-available/jitsi.conf

<VirtualHost *:443>
        ServerName meet.intern.lan
        SSLEngine on
        SSLProxyEngine on
        SSLProxyCheckPeerCN off
        SSLProxyCheckPeerName off
        SSLProxyCheckPeerExpire off
        SSLCertificateFile /etc/univention/ssl/*.gw01.intern.lan/cert.pem
        SSLCertificateKeyFile /etc/univention/ssl/*.gw01.intern.lan/private.key
        ProxyPass / http://localhost:8888/ retry=0
         ProxyPassReverse / http://localhost:8888/
</VirtualHost>

and:

a2ensite jitsi
systemctl restart apache2

On the Master → DNS I have edit the DNS alias from

Alias: jitsi.gw01  
Canonical name: gw01.intern.lan.

to:

Alias: meet.gw01  
Canonical name: gw01.intern.lan.

if I now call Jitsi from the LAN:

https://meet.intern.lan

Can I start a meeting but immediately gets the message “disconnected”. See:

grafik

The message runs in heavy rotation and does not disappear. Maybe it has something to do with the UCR variables that were set during the Jitsi installation:

root@gw01:~# ucr search --brief jitsi
apache2/vhosts/jitsi.gw01.intern.lan/443/aliases: 
apache2/vhosts/jitsi.gw01.intern.lan/443/enabled: true
apache2/vhosts/jitsi.gw01.intern.lan/443/files: /var/lib/univention-appcenter/apps/jitsimeet/config/vhost.conf
apache2/vhosts/jitsi.gw01.intern.lan/443/ssl/ca: /etc/univention/ssl/ucsCA/CAcert.pem
apache2/vhosts/jitsi.gw01.intern.lan/443/ssl/certificate: /etc/univention/ssl/*.gw01.intern.lan/cert.pem
apache2/vhosts/jitsi.gw01.intern.lan/443/ssl/key: /etc/univention/ssl/*.gw01.intern.lan/private.key
appcenter/apps/jitsimeet/container: e0211261ebe253fcdc0a2b823ed3154c95f62ed3493a09e247fcbba41678ef8e
appcenter/apps/jitsimeet/hostdn: cn=jitsi-33633204,cn=memberserver,cn=computers,dc=gehr,dc=lan
appcenter/apps/jitsimeet/image: docker.software-univention.de/jitsimeet-web:stable-6726-2
appcenter/apps/jitsimeet/ports/10000: 10000
appcenter/apps/jitsimeet/ports/4443: 4443
appcenter/apps/jitsimeet/status: installed
appcenter/apps/jitsimeet/ucs: 4.4
appcenter/apps/jitsimeet/version: stable-6726-2
jitsimeet/autostart: yes
jitsimeet/docker/host/address: 192.168.83.6
jitsimeet/enable/auth: true
jitsimeet/enable/guests: true
jitsimeet/ldap/filter: (&(uid=%u)(jitsimeetActivated=TRUE))
jitsimeet/public/url: https://jitsi.gw01.intern.lan
security/packetfilter/package/jitsimeet/tcp/10000/all/en: for RTP media over UDP
security/packetfilter/package/jitsimeet/tcp/10000/all: ACCEPT
security/packetfilter/package/jitsimeet/tcp/4443/all/en: for RTP media over TCP
security/packetfilter/package/jitsimeet/tcp/4443/all: ACCEPT
security/packetfilter/package/jitsimeet/udp/10000/all/en: for RTP media over UDP
security/packetfilter/package/jitsimeet/udp/10000/all: ACCEPT

with best
sven