Nicht synchronisierte S4 Connector Objekte


#1

Hallo Forum,
wir haben 3 USC-Server in einer Domäne. Die Systemdiagnose des primären Domänencontrollers gibt die Warnung auf nicht synchronisierte S4-Connector-Objekte aus mit folgenden Fehlerbeschreibung:

1 nicht synchronisierte UCS Objekte und 1 nicht synchronisierte S4 Objekte. Weitere Hinweise finden Sie unter Univention Support Database - How to deal with s4-connector rejects. 
Nicht synchronisierte UCS Objekte:
  UCS DN: cn=Console Logon,cn=Builtin,dc=internv2,dc=attomol,dc=de,
  S4 DN: cn=console logon,cn=builtin,DC=internv2,DC=attomol,DC=de,
  Dateiname: /var/lib/univention-connector/s4/1535664788.420860 

Nicht synchronisierte S4 Objekte:
  S4 DN: CN=Console Logon,CN=Builtin,DC=internv2,DC=attomol,DC=de,
  UCS DN: cn=console logon,cn=builtin,dc=internv2,dc=attomol,dc=de

Der angegebene Link (Univention Support Database - How to deal with s4-connector rejects) hat nicht weitergeholfen.
Welches der Objekte mit gleichem Namen soll gelöscht werden um danach eine erfolgreiche Synchronisation zu ermöglichen?

Vielen Dank für die Hilfe

Henning Hanschmann


#2

Hallo,

etwas zu löschen sollte immer die letzte in Betracht zu ziehende Variante sein.
Grundsätzlich muss man sich das Log vom Connector genau ansehen, machmal sind es Kleinigkeiten die man in der UMC oder mit Windows-Mitteln schnell korrigieren kann.
In diesem Fall sieht es aber nach https://forge.univention.org/bugzilla/show_bug.cgi?id=47310 so aus, als könnte man die UCR-Variable connector/s4/mapping/group/ignorelist um die fragliche Gruppe erweitern um den Reject zu beheben.

Viel Erfolg,
Dirk Ahrnke


#3

Hallo Herr Ahrnke,
danke für die ersten Tipps.

Ich habe die UCR Variable um die Gruppe “Console Logon” erweitert, und in den Logs ist erst einmal ein frischer reject hinzugekommen, der allerdings bis auf den Zeitstempel genauso aussieht wie der vorherige.

Muss man die Einträge in /var/lib/univention-connector/s4 (die Zeugen der rejects) dann löschen?
Wahrscheinlich, ganz sicher bin ich mir aber nicht.

Auch die verlinkten Artikel aus dem Bugzilla haben mich da nicht erleuchtet.

Haben Sie noch einen Tipp?

Danke und viele Grüße

Henning Hanschmann


#4

Hallo Herr Hanschmann,

ich habe leider genau dieses Problem selbst noch nicht gesehen, bin deshalb auch nur auf vergleichbare Situationen und Erfahrungen anderer angewiesen.
Wichtig wäre erstmal, die Syntax der UCR-Variablen zu prüfen und auch sicherzustellen, dass der S4-Connector neu gestartet wurde.
Soweit ich mich an eventuell vergleichbare Probleme erinnere, musste ich zumindest dann keine Rejects löschen, wenn die Ursache beseitigt war, aber das kann in diesem Fall auch anders sein.

Viele Grüße,
Dirk Ahrnke


#5

Hallo Herr Ahrnke,
am Ende führte ein Neustart des Connectors zum Erfolg. Das ist sicher nicht ganz zufriedenstellend was die Ursachenforschung angeht, aber der Erfolg zählt.
Vielen Dank für Ihre Unterstützung

Henning Hanschmann