NFSv4 "access denied by server while mounting [...]"


#1

Hello again guys,
I’m facing another issue now, concerning the NFS shares. Even through the forum, and articles I found (like https://wiki.univention.de/index.php/NFSv4_with_UCS or https://wiki.univention.de/index.php/Cool_Solution_-_NFS_with_UCS) I’m not able to make it works.

On my NFS server, I got this in the /etc/exports file :

“/home/my.name/” -rw,root_squash,sync,subtree_check * # LDAP:cn=nfsmyname,cn=smb.my.domain,cn=shares,dc=my,dc=domain

This share has not IP limitation at the moment.
When I try to mount it like this :

sudo mount -t nfs4 smb.my.domain:/home/my.name/ /home/my.name/nfs -o sec=krb5 (or without krb5 option, still the same)

I got the following error on the client side :

mount.nfs4: access denied by server while mouting smb.my.domain:/home/my.name/

But on the server side, in my /var/syslog I got this message :

Apr 2 17:46:01 smb rpc.mountd[24807]: authenticated mount request from 172.17.40.98:966 for /home/my.name (/home/my.name)

So currently, I tried different ways to do this, my SAMBA shares works perfectly, but I’m not able to make the NFS shares work. And honestly, I’m a little lost between the different articles from Univention about how to configure/mount NFS, there’s not a straight documentation for this.

Thanks for your help !


#2

Ok I’m self replying.
I just rebooted the server and successfully mounted the NFS share WITHOUT the KRB option.
I still got an “access denied” when I try to use -o sec=krb5.

Maybe it’s gonna be easier for somebody to guide me for this issue ?

Thanks :slight_smile:


#3

Hi,

why are you trying to force using krb5 as authentication? There are many requirements to meet to get it up and running so I assume they are simply not met.

There is an article for RedHat available and to mee this looks like it’s not really worth the effort because it’s just too complicated.

So i would suggest to simply skip krb5 option.

/CV


#4

Hi Christian,
I though it was kind of mandatory to auth the user, but you are right, it’s not. Thanks for this !

I still can’t explain why the NFS share wasn’t working before the reboot, it’s a pity.