NextCloud Upgrade 21.0.5-0 Problem

I have a server that has been continuously upgraded for UCS and for Kopano, Webapp, z-push, Guacamole, lets encrypt, NextCloud, and OnlyOffice.

I ran through all of the UCS updates and was also prompted for a NextCloud update to 21.0.5-0. Everything was running well prior to the update.

After the update to 21.0.5-0, NextCloud appears to be a fresh install and not an upgrade.

image

I tried a shutdown/restart cycle on the server without success with NextCloud. Any suggestions on recovering my existing NextCloud system?

Thank you!

I’m not sure what happened in your case. Just some tips. Do you see the Nextcloud instance if you list docker containers?

# docker ps

Is old Nextcloud user data still available?

/var/lib/univention-appcenter/apps/nextcloud/data/nextcloud-data

Is the Nextcloud configuration file present, looking OK?

/var/lib/univention-appcenter/apps/nextcloud/data/integration/config/config.php

This command provides access to the docker shell with Nextcloud if needed.

univention-app shell nextcloud

I’d also suggest reviewing UCR values filtered for “docker” and “nextcloud” to get a better feel for how Nextcloud is set up. Good luck!

  1. the NextCloud docker instance is shown. I can use the docker ps command to see the ID
  2. the NextCloud data appears to be present in the nextcloud-data folders inside the docker container
  3. there IS a config.php file at that location. It appears to be date/time stamped at the time of upgrade. Would it help to post the contents for review?

John

I’m not sure why the Nextcloud update did not see the existing configuration on your server. How about checking the UCS appcenter log?

# cat /var/log/univention/management-console-module-appcenter.log | grep nextcloud

I updated my Nextcloud recently too. Here is my output so that you could compare.

14.11.21 20:53:21.283  MODULE      ( PROCESS ) : Creating data directories for nextcloud...
14.11.21 20:53:21.283  MODULE      ( PROCESS ) : Copying /var/cache/univention-appcenter/appcenter.software-univention.de/4.4/nextcloud_20211103203520.schema
14.11.21 20:53:21.343  MODULE      ( PROCESS ) : Already found cn=nextc-94081241,cn=memberserver,cn=computers,dc=XXX,dc=XXX,dc=XXX as a host for nextcloud. Trying to retrieve machine secret.
14.11.21 20:53:21.504  MODULE      ( PROCESS ) : Registering UCR for nextcloud
14.11.21 20:53:21.504  MODULE      ( PROCESS ) : Marking 4.4/nextcloud=21.0.5-0 as installed
14.11.21 20:53:21.507  MODULE      ( PROCESS ) : Creating /etc/init.d/docker-app-nextcloud
14.11.21 20:53:24.765  MODULE      ( PROCESS ) : Checking if database nextcloud exists (postgresql implementation)
14.11.21 20:53:25.421  MODULE      ( PROCESS ) : Database nextcloud already exists
14.11.21 20:53:25.468  MODULE      ( PROCESS ) : 4.4/nextcloud=21.0.5-0 already has its database
14.11.21 20:53:25.862  MODULE      ( PROCESS ) : Registering schema /usr/share/univention-appcenter/apps/nextcloud/nextcloud.schema
14.11.21 20:53:27.060  MODULE      ( PROCESS ) : Registering attribute nextcloudUserQuota
14.11.21 20:53:27.206  MODULE      ( PROCESS ) : Registering attribute nextcloudUserEnabled
14.11.21 20:53:27.215  MODULE      ( PROCESS ) : Registering attribute nextcloudGroupEnabled

Are you making server backups you can restore from? You can try a manual Nextcloud uninstall and reinstall.

# univention-app remove nextcloud && univention-app install nextcloud

Prior releases of Nextcloud docker apps for Univention could be obtained from here. There should be a way to revert to an earlier version of Nextcloud.

Hi @jsatterfield

I would check/ compare the config.php file on both sides: on the ucs filesystem and inside the docker container. And also check the owner and file permissions. I once forgot to change it back after some changes with root-user and had the same issue.
If it can’t be copied during the upgrade it will be recreated.

Best, Bernd

Bernd, Your guidance pointed me to the proper solution. For me, the config.php file in the web root and the nextcloud app needed to be the same.

Thank you!