Nextcloud Sicherheitswarnungen

Moin Zusammen,

Nextcloud in der letzten Version läuft auf unserem UCS-System. Zur Zeit erhalten wir noch nachfolgende Fehlermeldung ( siehe Bildanlage ).

04-11-_2020_12-01-34

Leider ist uns nicht so recht klar, wo wir das unter UCS bearbeiten können und was wir genau machen müssen um dieses Problem zu “entschärfen”. Könnte uns jemand aus der Community auf die “Sprünge” helfen …

Vielen Dank an alle die helfen wollen und können
Nexxo, Hamburg

Für eine “Quick and Dirty”-Lösung, um weiterzukommen:

Es fehlen die Einträge

    Redirect 301 /.well-known/carddav https://ucs-domainname/nextcloud/remote.php/dav
    Redirect 301 /.well-known/caldav https://ucs-domainname/nextcloud/remote.php/dav

als letzte Zeilen in der /etc/apache2/sites-enabled/default-ssl.conf

<IfModule mod_ssl.c>

<VirtualHost *:443>
...
    Redirect 301 /.well-known/carddav https://ucs-domainname/nextcloud/remote.php/dav
    Redirect 301 /.well-known/caldav https://ucs-domainname/nextcloud/remote.php/dav

</VirtualHost>
</IfModule>

Das Problem:
Nach jedem “ucr commit” werden diese Zeilen gelöscht.
Um das dauerhaft zu lösen, muss man sich in die Erstellung von UCR-Templates einarbeiten.

Moin,

vielen Dank für Dein Feedback. Leider funzt es bei mir noch nicht so recht. Habe ich etwas falsch eingetragen?

Redirect 301 /.well-known/carddav https://\<www.gsh-work.de\>/nextcloud/remote.php/dav
    	Redirect 301 /.well-known/caldav https://\<www.gsh-work.de\>/nextcloud/remote.php/dav

Viele Grüsse
Nexxo, Hamburg

Sorry, die Spitzen Klammern waren als Kennzeichen für einen Platzhalter gedacht.
Das “\<” und “\>” muss jeweils entfernt werden.

Die Forensoftware der verschiednen Hersteller kann interpretiert oft die Spitze Klammer als Steuerzeichen, dem man durch vorastellen des Backslash vorbeugen kann.

Ich habe die Zeilen im Beitrag oben entsprechend geändert.