Nextcloud Join Script failed


today i tried to install nextcloud to a ucs server. But when i run the join script there is a failure:

univention-run-join-scripts started
Mi 23. Aug 16:40:14 CEST 2023

univention-join-hooks: looking for hook type "join/pre-joinscripts" on ucs-2018.XXX.intranet
Found hooks:

RUNNING 50nextcloud.inst
2023-08-23 16:40:16.016968770+02:00 (in joinscript_init)
Object exists: cn=services,cn=univention,dc=XXX,dc=intranet
Object exists: cn=Nextcloud Hub,cn=services,cn=univention,dc=XXX,dc=intranet
No modification: cn=ucs-2018,cn=dc,cn=computers,dc=XXX,dc=intranet
WARNING: cannot append Nextcloud Hub to service, value exists
Not updating nextcloud/ucs/modifyUsersFilter
Not updating nextcloud/ucs/userEnabled
Not updating nextcloud/ucs/userQuota
Not updating nextcloud/ucs/debug
Not updating nextcloud/ldap/cacheTTL
Not updating nextcloud/ldap/homeFolderAttribute
Not updating nextcloud/ldap/userSearchAttributes
Not updating nextcloud/ldap/userDisplayName
Not updating nextcloud/ldap/groupDisplayName
Not updating nextcloud/ldap/base
Not updating nextcloud/ldap/baseUsers
Not updating nextcloud/ldap/baseGroups
Not updating nextcloud/ldap/filterLogin
Not updating nextcloud/ldap/filterUsers
Not updating nextcloud/ldap/filterGroups
LDAP Error: No such object.

univention-join-hooks: looking for hook type "join/post-joinscripts" on ucs-2018.XXX.intranet
Found hooks:

Mi 23. Aug 16:40:18 CEST 2023
univention-run-join-scripts finished

I think it is a problem with the .intranet TDL. What i did was:

1.) enter the IP and the hostname (.intranet and the external dyndns names into the hosts file (nextcloud dokker and lokal system)
2.) hardcode the hostname ucs-2018.XXX.intranet to the 50nextcloud.inst script
3.) hardcode the dyndns hostname to the 50nextcloud.inst script
4.) commented out the nextcloud_configure_saml line in the 50nextcloud.inst script

These are the sugesstions i found in old therad but nothin worked.

Can you please give me a hint how to fix this?

Kind regads


Hi Jochen,

i got the same error message today and focused on the “LDAP Error: No such object” message. The error is thrown when the join script tries to add an LDAP entry into the “saml-serviceprovider” container because that container didn’t exist.

I could solve this by manually creating the “saml-serviceprovider” container underneath the “univention” container and running the join script again. Afterwards the login for Nextcloud worked as expected.

Best regards