Nextcloud – Internal Server Error when accessing external CIFS storage


I am experiencing some strange issues when trying to access external cifs storages from Nextcloud 18.0.6.

The server is a Server 2019. Some shares work, on some shares I am always getting a “internal server error” when the test user tries to access the folder. I cannot narrow it down to any similarities. Ntfs and share permissions are the same. The user can access all the shares from windows explorer without any issues.

The error log looks like this:

{“reqId”:“Q3sp3Ll1Kf4BgkBQi14a”,“level”:3,“time”:“2020-07-06T13:01:26+00:00”,“remoteAddr”:“x.x.x.x”,“user”:“B77CC5B6-0E6E-4772-9595-C0734277D01D”,“app”:“PHP”,“method”:“GET”,“url”:"/nextcloud/remote.php/webdav/Daten",“message”:“Undefined index: debugMode at /var/www/html/core/templates/exception.php#26”,“userAgent”:“Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36”,“version”:“”}

Any ideas?



Hello? Any idea anyone? :no_mouth:

Google search for [quote=“michael-hennemann, post:1, topic:15552”]
“message”:Undefined index: debugMode at /var/www/html/core/templates/exception.php
lead me to this page:

Even it concerns version 18.0.4, it might been happened, that the error related file still is present on your system.

Hi Mornsgrans,

thanks for your reply! :slight_smile:
I think I’ve stumbled over this thread during my googeling but if I understand correctly, the issue should be fixed in 18.0.5

My nextcloud on UCS is already on 18.0.6


You are right, but you should check and test out, whether the menioned php-file is the right one for your recent Nextcloud version.


I just found time for my nextcloud experiment – sorry for the delay!

I just read the thread and tried to find out which file exactly to check. Is it this one?


How can I check if it is the right version?

Btw: I started with a fresh clean installation and it was UCS Nextcloud App 18.0.6 from the beginning. Is it really possible, that I got the wrong file version?



Are you sure, that the Server 2019 can handle the Linux permissions? What will happen, if you share via Samba to a Linux system? - Does the error still appear then?
What does the Windows Event-Viewer tell, if you attempt to access the share?

Hi Mornsgrans

Yes, it definitely can! I’ve created other shares on the same host and tested with the same user. I checked the share and ntfs permissions.

I was even able to create a new share within one of the sub-sub-sub-folders that works.

For me it looks like Nextcloud stumbles over some content (files, folders, subfolders) within the share. I just cannot isolate it. Some folders seem to work for no reason and others do not.

And then again: When I open the share in windows explorer everything works fine.



Do those subfolders have the same Windows- and Linux-permissions as the root-folder of the share? Perhaps the are inherited restrictions in the root folder of the share active.

But starting from now I have no opinions anymore, how to help you. Sorry for that.

Yes, I tried with a share in a subfolder that wasn’t working and forced the inheritance to all subfolders but no luck.
Thanks for your help so far!! :slight_smile:

Somebody else got an idea ?

Did you try the workaround as described here?

Assuming I did everything right, the error is still the same :-/

  • I downloaded NC 18.0.03 ZIP and extracted everything
  • I packed the folder nextcloud\apps\external_files in a new tar file
  • copied the file with winscp to my UCS host
  • copied the file with docker cp into the nextcloud container
  • moved it to /var/www/html/apps/files_external
  • extracted it with tar -xvf files_external.tar in the current dir

Sorry, but now I have no more ideas. - It might be more helpful to ask in the nextcould forum, because it seems to be a special Nextcloud problem but not Univention one.