Nextcloud downgrade after UCS upgrade 4.4 to 5.0-1

I updated a test system from 4.4 to the newest 5.x version and now nextcloud complains about a downgrade.
Is it correct that UCS 4.4 uses Nextcloud 21.0.7 and UCS 5.x is still on Nextcloud 21.0.5 and when will this change?

Kind regards


I have recently installed a fresh 5.0-1 errata174 with nextcloud 21.0.7 as suggested packet. The same on my elder 5.0-0 errata174 installation.

Please post the following outputs:

univention-app info

univention-app list |grep --color -A2 -i next

ucr search repository/online/server

docker images |grep next

Hello Santiago.

thank you for the quick response.
Below you see the commands and their output.
I’ll try to run “univention-upgrade” next

Best regards

root@ust1# univention-app info

UCS: 5.0-1 errata177
Installed: admindiary-backend=1.0 admindiary-frontend=1.0 letsencrypt=2.0.0-2 mailserver=12.0 pkgdb=11.0 self-service=5.0 self-service-backend=5.0 4.4/collabora= 4.4/nextcloud=21.0.5-0 4.4/wordpress=5.2.3
Upgradable: nextcloud

root@ust1# univention-app list | grep --color -A2 -i next

  Name: Nextcloud Hub
  Latest version: 21.0.7-0

root@ust1# ucr search repository/online/server

 The repository server from which software packages are retrieved. If the variable is unset, <> is used. If an URI is given instead on a hostname, this also overwrites '.../port' and '.../prefix'.

root@ust1# docker images | grep next           21.0.7-0            1c36271a798a        7 weeks ago         1.18GB           21.0.5-0            1b9c0aa1ff67        2 months ago        1.18GB

Ok. There is something else now. “univention-upgrade / upgrade.log” ends with:

Nextcloud Hub: Version 21.0.5-0 can be upgraded to 21.0.7-0
Starting univention-app upgrade at Thu Jan  6 10:18:20 2022...
Most of the output for App upgrades goes to /var/log/univention/appcenter.log

Starting app upgrade                                   Traceback in univention-upgrade:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/univention/updater/scripts/", line 430, in do_update
    update_available = performUpdate(options, checkForUpdates=options.check, silent=False)
  File "/usr/lib/python3/dist-packages/univention/updater/scripts/", line 139, in performUpdate
    if func(options, checkForUpdates, silent):
  File "/usr/lib/python3/dist-packages/univention/updater/scripts/", line 314, in do_app_updates if options.pwdfile else None,
  File "/usr/lib/python3/dist-packages/univention/appcenter/actions/", line 167, in call_safe
  File "/usr/lib/python3/dist-packages/univention/appcenter/actions/", line 175, in call
    return obj.call_with_namespace(namespace)
  File "/usr/lib/python3/dist-packages/univention/appcenter/actions/", line 181, in call_with_namespace
    result = self.main(namespace)
  File "/usr/lib/python3/dist-packages/univention/appcenter/actions/", line 75, in main
    for app in apps:
TypeError: 'App' object is not iterable

Hello Mark,

as you can see in your docker docker images | grep next request you are dealing with two different nextcloud versions on your system : 21.0.7-0 1c36271a798a 7 weeks ago 1.18GB 21.0.5-0 1b9c0aa1ff67 2 months ago 1.18GB

So the question is what happend 7 weeks ago?

I don’t belive just trying to do an upgrade will change the problem. You should find out why this old , nextcloud container wasn´t removed.
appcenter.log and updater.log in /var/log/univention/ are helpfull informands for that kind of questions. You can backup your Nextcloud data in /var/lib/univention-appcenter/apps/nextcloud/data/nextcloud-data/. This might become helpful after getting rid of this situation.

Best regards

PS Please also send your:

dpkg -C

dkpg -C |–audit [ …] Check for damaged package(s).

Hello Santiago,

nextcloud 21.0.7-0 was installed 7 weeks ago (?) while I was running UCS 4.4. (at last it was running before the upgrade).
After the upgrade UCS 4.4 to UCS 5.0-1 nextcloud disappeared from the portal und the app center showed no installation of nextcloud. In the logs I found that the nextcloud data is still saved but something happend to the nextcloud app installation. (I assumed that the app was removed.) So I used the app center to install nextcloud again.

I have a tar file as backup of nextcloud-data

dpkg -C produces no output. So it looks like there is everything go with the installed packages.

Best regards

Hello Santiago,

it looks like I fixed it. Removing the nextcloud installation and installing it again should do the main part of the job. Then I had to deactivate und reload some apps inside the nextcloud. They showed up with a version of “0”.
All data looks good as far as I can see.

Before I tried the steps above I checked some other steps:

  • docker image prune -a gave me a better overview of used containers
  • docker container stop xxx and docker container rm xxx removed the nextcloud 21.0.7 container manually
  • after removing the nextcloud app (using the web interface) I checked docker again removing what still was found there from the nextcloud app.

Thanks and best regards

Hello Mark,

good to hear that thing came back to normal and thanks for sharing.
To recite an old friend "Have fun with the machine… " :slight_smile:

Best regards

See also → Problem: App upgrade stucks in removing old container

Hello Mark, we published a bug today which might be the root cause for this behavior. To avoid further problems please consider the workaround or wait till we’ve publishes an errata and follow the instructions.

Hello @MarkD FYI
We have publised an errata which should avoid this from happening again.

Hello Santiago,
thank you for this information. The errata is installed on my system now. We’ll see if the behavior occurs again. I am not sure how I can reproduce it.

Best regards

Thursday evening we installed the latest updates. (Jetzt UCS 5.0-1 errata317 and Nextcloud 23.0.4-0)
Some days later I was informed that the Nextcloud is not available. In UCS App Center Nextcloud was marked as ‘not installed’.
This commands solved the problem:

univention-app remove nextcloud
univention-app install nextcloud
univention-app install nextcloud

The second ‘install’ was necessary. I’ll try to find out more the next days.

Best regards