Nextcloud default files

nextcloud

#1

Hi,
I would like new users of nextcloud when added don’t see default files.

Nextcloud official administration manual says to edit the parameter ‘skeletondirectory’ of the config.php file and set it as empty (‘skeletondirectory’ => ‘’).

I added such parameter (not present originally) but it doesn’t work… new users see the dfault files.

Can anybody help me???


#2

Hello @Ethicaweb!

Just FYI: I moved your topic to the category “Apps & App Center” and tagged it with “nextcloud”.

I assume that we need to adjust the config.php file inside the Nextcloud Docker Container (switch in the container via univention-app shell nextcloud). Is that the one you modified? Can you give us the exaxt path to the file?

Best regards,
Michael Grandjean


#3

The config.php I adjusted is in the /var/lib/univention-appcenter/apps/nextcloud/conf/config/ path. Is it not correct?


#4

It’s merely a backup.

univention-app shell nextcloud
vi /var/www/html/config/config.php

Mind that vi is not installed on the container by default, so you apt install it for instance.


#5

That file is not present. In the path /var/www/html/ there is only the file index.html.


#6

I found the file I have to modify, but when I try to install vi first (“apt-get install vim” and then “apt install vim”), it doesn’t work… temporary failure resolving ‘archive.ubuntu.com. Why??? I’m not an expert of linux.
I also tried nano “/var/www/html/config/config.php” instead of vi but nano: command not found

Please help me!!!


#7

I was able to edit the config.php file as follow.

  1. docker cp id_docker:/var/www/html/config/config.php . in order to copy the file from docker to my documents folder
  2. I add the line ‘skeletondirectory’ => at the end of the file
  3. docker cp config.php id_docker:/var/www/html/config/config.php in order to copy back the file on the docker

When I try to connect to nextcloud, I have this error:
Errore interno del server
Il server non è stato in grado di completare la tua richiesta.

Se ciò si verifca nuovamente, invia i seguenti dettagli tecnici all’amministratore del server.

Ulteriori dettagli sono disponibili nel log del server.

Dettagli tecnici
Indirizzo remoto: 172.17.42.1
ID richiesta: zSBQtPvIexh6zgckLTg7

I don’t know why?!?! :disappointed_relieved:


#8

I’ve created a new vm with univention and reinstalled nextcloud. I was able to access the cointaner, to install vi and to edit the config.php file.

The problem now is that when I try to access nextcloud I have an empty page (index.php).

Help!!!


#9

Everything solved! :star_struck:


#10

Hi Ethicaweb, just curious, could you share how you solved the issue? I can’t seem to be able to solve it for a few days now as well. Also, since i’m very new to linux commands - what does id_docker refer to ? or is that part of the command?
Thank you for your help in advance!


#11

Type these command as root

If vi is not installed on the docker, you should do that


#12

Whenever i use the command ‘univention-app shell nextcloud’ - it doesn’t detect nano or vi as commands. How does one install it? and what is the nextcloud shell? i’m a bit new. lol


#13

apt-get install vim/nano


#14

Ethicaweb, thank you so much.
Took me a bit to figure out how to use vim. nano for some reason didn’t work after i tried vim and it did the tilde thing because i entered the wrong commands. After fiddling around with the *i commands and the ‘esc’ ‘:’ and ‘qw’ i got the hang of it. Wouldn’t have figured out to access docker separately. Thanks alot!