Next Cloud failing to Join

nextcloud

#1

Hello,

I am running Univention Coporate Server and wanted to install Next Cloud. Installation goes through but when i try and log in it says wrong username and/or password. I have ticked two user accounts to enable NextCloud but still cannot log in.

If i go domain join i can see 50nextcloud in pending state. If i run the script it says it fails. In join.log i see the following -:

curl failed with error 51
EXITCODE=51

Fri 22 Dec 08:29:44 GMT 2017
univention-run-join-scripts finished

I have tried uninstalling and reinstalling but problem still exists.

Server is running -:

4.2-3 errata254

All software is up to date.

Does anyone have any ideas what the above error message means ?

Thank you for your help !


Join-script error after installing Wordpress
#2

Hello,

Still having the same problems, tried removing nextcloud, rebooting server and reinstalling, any ideas what to check ?

thanks for your help.


#3

Hi,

can you please paste the content of /var/log/univention/join.log after executing univention-run-join-scripts?

(Only the lines of the last run)

Maybe we can find the issue there.

Kind regards,
Dirk Wiesenthal


#4

Good afternoon,

Thank you for replying, i have run the command univention-run-join-scripts and get the following output on the screen -:

Running 50nextcloud.inst failed (exitcode: 51)

the only information in the log is -:

curl failed with error 51
EXITCODE=51

Please let me know what else i can check.

Thank you for your help !


#5

Hmmm… this is a very compact error message…

You could try it again with
ucr set nextcloud/ucs/debug=1
right before univention-run-join-scripts. This should at least give us a hint which curl call failed.

But my guess is that it is the first one and it would fail on any other, too. Because 51 is:

The peer’s SSL certificate or SSH MD5 fingerprint was not OK.

Did you install a custom certificate on the system? Or on the DC Master of your domain if this is not the Nextcloud machine? Are you using Let’s encrypt?

Kind regards,
Dirk Wiesenthal


#6

Hi Dirk,

To answer the lets encrypt - we are using lets encrypt but not for the server name - would this be causing the issue ?

Thanks,

Mark.


#7

Hello,

I ran the join script with the debug mode switched and i get the following error in join.log -:

curl failed with error 51, parameters were\n\t-X POST -H OCS-APIREQUEST: true -u https://localservername.domainname/nextcloud/ocs/v2.php/apps/user_ldap/api/v1/config

localservername.domainname being the local server full qualified name. The Lets Encrypt certificate i installed is not for the name of the local server.

I have removed the nc username and password string from the output

Does this help ?

Many thanks,

Mark.


#8

Hello,

After doing a bit more searching through the forums and testing, i have resolved the issue. My solution was -:

Server had an Lets Encrypt Certificate for a domain name which was not the name of the server EG mail.domain.com but server name was server.domain.com

I uninstalled NextCloud.
Created Public DNS A Record to match server domain name.
Added additional domain record to Lets Encrypt
Re-installed NextCloud which installed and joined the server successfully.
Testedt account logins and all working.

So, issue looks like NextCloud Join script was unable to use the local certificate for the server while Lets Encrypt was installed but not adding the local server domain to Lets Encrypt as well.

Hope this helps others who gets stuck.

Thank you all for your help.