New UCS 4.2 install fails at GRUB

grub
ucs-4-2

#1

Downloaded the ISO today (7/28/2017) and burned to DVD.

Tried letting the partitioner install separate partitions for /home, /root, /swap, /tmp, etc and also tried letting them all exist on one partition and both installs failed. Attached are two screen caps of it happening. I’ve tried rescue mode to no avail. The /dev/sda/ drive is plugged directly into the motherboard and the raid card is running a separate volume for user storage.

Also attached is the dmidecode output txt file from it’s sister server currently running FreeBSD. These two servers are exactly the same.


DMIdecode.txt (22.2 KB)


#2

Do you have /boot on a separate partition? Which file system is /boot using (both if it’s a separate partition as well as if it’s part of the root partition; in the latter case what’s the root partition’s file system)?


#3

I have two drives. One 240GB SSD for boot ( /dev/sdb ) and the raid drive. As I stated before the boot drive is connected to the motherboard and the raid is connected to an LSI raid card. The only OS installed is UCS.

Rescue mode reports:

/dev/sdb1
/dev/sdb2
/dev/sdb5
/dev/vg_ucs/home
/dev/vg_ucs/root
/dev/vg_ucs/swap_1
/dev/vg_ucs/tmp
/dev/vg_ucs/var


#4

Interesting. While you’re in the rescue system, try installing grub manually and post a photo of the output. Please also post a photo of the partition tables of both drives, e.g. fdisk -l /dev/sda and fdisk -l /dev/sdb.

As for installing grub, this is roughly done like this:

  1. Mount a couple of partitions: mount /dev/vg_ucs/root /mnt, mount /dev/vg_ucs/var /mnt/var and mount /dev/sdb1 /mnt/boot (assuming /dev/sdb1 contains /boot; adjust as necessary)
  2. Mount the dev and proc pseudo file systems: mount /dev /mnt/dev -o bind and mount -t proc proc /mnt/proc
  3. Now chroot into it and run grub: chroot /mnt /bin/bash followed by update-grub and grub-install /dev/sda

#5

funny enough fdisk -l /dev/sda turned out to be the raid drive in the rescue system and /dev/sdb ended up being the boot drive. I need to watch the next install to determine if the partitioner is formatting sda or sdb. I’ll update again probably late tomorrow about this. Maybe it’s getting confused and trying to put grub on the wrong drive which is why it fails.

I did follow your rough (but good enough, thanks) instructions and get grub installed and successfully boot the server.


#6

Congratulations. It’s possible that the installer was confused by the order for some reason. Doing a quick search through the bug tracker I wasn’t able to find anything that matches your issue, though.


#7

Well spoke too soon. I was updating this install because it never finalized correctly and gorked itself after I installed some missing items with apt. I’ve reinstalled and followed your instructions but now I just get a black screen with a blinking underline cursor on it and that’s it. It never boots. And yes I’m installing on the same drive in the same server.


#8

Here are the screenshots from fdisk for /dev/sdb

And the output from update-grub and four carriage returns and then grub-install /dev/sdb


#9

It looks to me as if your computer is looking for a boot loader on a drive where there’s no boot loader installed. I suggest you boot into the rescue system and enter the chroot as I’ve described above, and then run grub-install for both /dev/sda and /dev/sdb.

While you’re at it we should verify that the settings in two of the relevant configuration files match the actual disks. For that execute the following programs and post screenshots, please:

  • From the chroot environment:
    • cat /etc/fstab
    • grep root /boot/grub/grub.cfg
  • From outside the chroot environment:
    • blkid

Thanks.


#10

Output from cat/etc/fstab in chroot after mounting /dev/vg_ucs/root

Output from grep root /boot/grub/grub.cfg

Output from blkid


#11

Thanks for the screenshots. The values all match properly:

  • The /boot parition’s UUID is the one from /dev/sdb1, and it’s the one used in grub’s grub.cfg (the search… line).
  • The root partition is on an LVM and named root in the volume group vg_ucs. The correct path is used both in fstab and in grub.cfg (the linux… root=… line).

So please try installing grub on both /dev/sda and /dev/sdb from the chroot as I’ve written above.


#12

I tried to install to /dev/sda and it errors out (boot also failed), then I installed to to both /dev/sda and then /dev/sdb neither works when trying to boot, just a black screen with a blinking cursor both times. I noticed that the grub config looked fine, I compared it to a server with a single drive and it seemed in line with how it was constructed.


#13

The time it did boot was when I had /dev/sda (raid array) formatted as UFS2 (Freebsd UFS) but upon finding that UCS wouldn’t read the UFS format I re-formatted with with ext4.


#14

If you can’t install a bootloader on the first hard disk, then you’ll have to look at your BIOS/UEFI to change which hard disk it tries to boot from. In many situations you can either change the ordering of hard drives in BIOS/UEFI or at least which hard disk to try to boot from first. Please look there for a solution.