New network adapter messes up DNS settings

Hey forum,
I have a problem with setting up a second ethernet card.
base system is a VPS (netcup) with a second cloud vlan interface (netcup Cloud vLAN) which should be handled as a second network adapter.

When I do a fresh install on the VPS as UCS master I already have the following errors:

I assume the first one is a flase positive, I have read in a different article, the second one I ignore, as the warning is also present on another system I have, without consequences.

As Domänen DNS Server there is the static/public ip of the master. The external DNS are netcup’s DNS server.


When I add the second ethernet, the new Domain DNS ist automatically changed to the new “internal” ip.

and the system diagnostics goes wild

I have tried adding the pulic ip as additional DNS server, searched for problems in the LDAP and DNS settings, but nothing really jumped to me, to solve the problem.

Can you guide me into the right direction?

Thank you!


I did not understand your setup fully but just asking: if the 192… DNS server setting results in a lot of issues why do you not set it back to the previous (public?) IP? You’ve already been on this screen.

BTW: Do you have Samba installed on this server? If so your KDC error messages should be handled!


Hey Christian,

I tried changing back to the original state. However, the errors remain. I also tried to used both ips as DNS servers.


I am confused…
Especially that the namesserver with the public ip now should not be reachable, although it has been moments before.

Oh and no, Samba is not installed.

I found the problem:
In the device settings the Forward and Reverse Lookup Zones were empty after adding the second ethernet card. Correcting this solved all the problems.
Still strange behaviour though…