Nagios setup: dashboard is 404 and notifications

nagios

#1

Hi. It seems that /nagios webpage is nonexistent as gives me 404 result.
And also I cannot find where in UCS to specify contact email for notifications, I had to go into each server in Computers and type my email there. Is this as per design?


#2

Regarding email notifications the person on IRC suggested to change mail/alias/root UCR and it worked.


#3

Nagios it not installed by default. You could install it in the Univention Management Console from the “App Center”. See the documentation:

http://docs.software-univention.de/manual-4.1.html#Nagios:Installation

In my case 12 packages were installed on the master, and after that the dashboard is available at:

https://SERVERNAME-OR-IP/nagios/


#4

Sorry I should have mentioned. It is Nagios monitoring server with nagios app installed. It does checks and sends notifications. Maybe something else I need to install?


#5

In a fresh system not all nagios packages and dependencies are installed. This results in a missing dashboard.

Have you installed Nagios from the “App Center” or by executing “univentions-install univention-nagios-server”? – both should work and will automatically install all missing dependencies.

After that running a Nagios check manually will work i.e. check that no join script has to be executed

~# /usr/lib/nagios/plugins/check_univention_joinstatus
OK: system joined successfully

The dashbord itself is located at “/usr/lib/cgi-bin/nagios3” and the Apache config is “/etc/nagios3/apache2.conf”. For the 404 error you could check the output of “/var/log/apache2/error.log”


#6

The server was installed before me by it exists in UCS management panel. Please see my results below:

~# /usr/lib/nagios/plugins/check_univention_joinstatus
OK: system joined successfully

~# univention-install univention-nagios-server
univention-nagios-server is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ ls /usr/lib/cgi-bin/nagios3/
avail.cgi extinfo.cgi notifications.cgi status.cgi statuswrl.cgi trends.cgi
cmd.cgi histogram.cgi outages.cgi statusmap.cgi summary.cgi
config.cgi history.cgi showlog.cgi statuswml.cgi tac.cgi

cat /etc/nagios3/apache2.conf
(comments removed)

ScriptAlias /cgi-bin/nagios3 /usr/lib/cgi-bin/nagios3
ScriptAlias /nagios3/cgi-bin /usr/lib/cgi-bin/nagios3
ScriptAlias /cgi-bin/nagios /usr/lib/cgi-bin/nagios3
ScriptAlias /nagios/cgi-bin /usr/lib/cgi-bin/nagios3

Alias /nagios3 /usr/share/nagios3/htdocs-nuvola
Alias /nagios /usr/share/nagios3/htdocs-nuvola


<DirectoryMatch (/usr/share/nagios3/htdocs|/usr/share/nagios3/htdocs-nuvola|/usr/lib/cgi-bin/nagios3)>
	Options FollowSymLinks

	DirectoryIndex index.html index.php

	AllowOverride AuthConfig
	Order Allow,Deny
	Allow From All

	AuthBasicAuthoritative Off
	AuthUserFile /dev/null

	AuthPAM_Enabled on
	AuthPAM_Service nagios
	AuthName "Nagios Access"
	AuthType Basic
	require valid-user

</DirectoryMatch>

<Directory /usr/share/nagios3/htdocs>
	Options	+ExecCGI	
</Directory>

$ ls /usr/share/nagios3/htdocs-nuvola
config.js contexthelp docs images index.html license.txt main.html readme.txt side side.html stylesheets

Update: I think that Apache does not know about /etc/nagios3/apache2.conf
user@nagios:/etc/apache2$ grep -i -r nagios *
user@nagios:/etc/apache2$


#7

I have posted update question in my message above:

Update: I think that Apache does not know about /etc/nagios3/apache2.conf
user@nagios:/etc/apache2$ grep -i -r nagios *
user@nagios:/etc/apache2$


#8

I fixed it for myself by copying /etc/nagios3/apache2.conf file to /etc/apache2/sites-available/ but probably worth looking at why did it not work in the first place.

Thanks.


#9

For Apache there is “/etc/apache2/conf.d/nagios3.conf”, which is a symbolic link to the configuration file above. Sadly only “grep -iR nagios” with a capital “R” will find some results.

Glad to hear that you fixed it. Maybe a restart of apache would have also helped.


#10

maybe for some reason it failed to create this on my server that is why it did not work. Thanks for help.