Nach Upgrade auf USC 3.2 Smaba startet nicht mehr

german

#1

Hallo,

nach dem Upgrade auf 3.2 habe ich keinen Zugriff mehr auf die Netzwerkfreigaben (Samba).

Im Logfile steht dieses:

[2013/11/20 06:50:51.449346, 0, pid=4562] …/source4/smbd/server.c:372(binary_smbd_main)
samba version 4.1.0-Debian started.
Copyright Andrew Tridgell and the Samba Team 1992-2013
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib//ldb/modules/ldb/univention_ldb_log.so : Unavailable

[2013/11/20 06:50:51.494256, 0, pid=4563] …/source4/smbd/server.c:501(binary_smbd_main)
samba: using ‘standard’ process model
[2013/11/20 06:50:51.560459, 0, pid=4573] …/file_server/file_server.c:48(file_server_smbd_done)
file_server smbd daemon exited normally
[2013/11/20 06:50:51.560514, 0, pid=4573] …/source4/smbd/service_task.c:35(task_server_terminate)
task_server_terminate: [smbd child process exited]
[2013/11/20 06:50:51.561442, 0, pid=4563] …/source4/smbd/server.c:213(samba_terminate)
samba_terminate: smbd child process exited

Ich habe versucht diese Datei zu finden, vor dem Update war diese vorhanden, nachher nicht mehr. Wie bekomme ich diese Datei oder in welcher Konfig muss ich etwas ändern? Auf einer Freigabe liegt die DB des Bankingprogrammes.

Volker


#2

Hallo,

univention_ldb_log.so ist ein UCS@school Modul, daher habe ich Ihren Thread verschoben. Die Datei kommt aus dem Paket “libunivention-ldb-modules”, evtl. gab es hier ein Problem während des Updates, die /var/log/univention/updater.log und /var/log/dpkg.log sollten hier weitere Hinweise enthalten.

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo,

ich hatte vorher einmal UCS@School zu testzwecken mit installiert aber dann wieder deinstalliert. War wohl ein Rest noch vorhanden.

Im Updater finde ich diese Einträge:

ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib//ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib//ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib//ldb/modules/ldb/univention_ldb_log.so : Unavailable
ERROR: Failed to connect to DB at None. If this is a really old sam.ldb (before alpha9), then try again with --force-modules
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib//ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib//ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib/ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: failed to initialise module /usr/lib/ldb/modules/ldb : Unavailable
ldb: failed to initialise module /usr/lib/ldb/modules : Unavailable
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib/ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: failed to initialise module /usr/lib/ldb/modules/ldb : Unavailable
ldb: failed to initialise module /usr/lib/ldb/modules : Unavailable
ldb: module version mismatch in …/modules/univention_ldb_log.c : ldb_version=1.1.16 module_version=1.1.15
ldb: failed to initialise module /usr/lib/ldb/modules/ldb/univention_ldb_log.so : Unavailable
ldb: failed to initialise module /usr/lib/ldb/modules/ldb : Unavailable
ldb: failed to initialise module /usr/lib/ldb/modules : Unavailable

Wie bekomme ich diesen Fehler weg?


#4

Hallo,

ich schätze es reicht das Paket libunivention-ldb-modules zu deinstallieren, das sollte die unter UCS nicht benöigten Module entfernen.

Mit freundlichen Grüßen
Janis Meybohm