MySQL Parameter

german

#1

Guten Tag,

obwohl ich in der Datei /etc/mysql/my.cnf den Parameter “innodb_buffer_pool_size = 1024M” eingestellt habe wird dieser nicht übernommen. Bei der überprüfung mit dem MySQL Tool “tuning-primer.sh” wird immer noch die Größe von 8MB angezeigt:

INNODB STATUS
Current InnoDB index space = 304 M
Current InnoDB data space = 1.95 G
Current InnoDB buffer pool free = 0 %
Current innodb_buffer_pool_size = 8 M
Depending on how much space your innodb indexes take up it may be safe
to increase this value to up to 2 / 3 of total system memory

Was kann hier der Fehler sein?


#2

Hallo,

die Variable innodb_buffer_pool_size ist unterhalb des Config-Punktes “[mysqld]” zu setzen.
Hierzu ein kurzer Auszug aus der Datei “/etc/mysql/my.cnf”:

[code][mysqld]

* Basic Settings

user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
innodb_buffer_pool_size = 1024M[/code]

Nach einem anschließend Neustart des MySQL-Servers:

invoke-rc.d mysql restart

Konnte der Wert sowohl mit dem von Ihnen verwendeten Skript, als auch direkt in mysql verifiziert werden:

[code]root@master:~# mysql
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 148
Server version: 5.0.51a-24.26.200910141858 (Univention)

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the buffer.

mysql> show variables;[/code]

Mit freundlichen Grüßen,
Tim Petersen