Mount von CIFS über FSTAB nicht möglich

german

#1

Guten Abend,

das wollte ich schon die ganze Zeit mal schreiben, ich hab an meiner Fritzbox eine kleinere Festplatte angeschlossen und wollte vom UCS-PDC darauf zugreifen.
Bei den “normalen” Linux-System von Debian und Ubuntu klappt das einwandfrei mit folgendem Befehl

//10.0.0.1/zentrale/Seagate-Backup-Desk-01/Batman /fritznas cifs uid=0,guid=0,rw,credentials=/etc/.cifspasswd 0 0

Das Verzeichnis ist auf dem Server angelegt. Auch wenn ich keine UID/GUID erzwinge funktioniert es nicht. Ich bekomme immer wieder die Meldung
mount: wrong fs type, bad option, bad superblock on //10.0.0.1/zentrale/Seagate-Backup-Desk-01/Batman,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount. helper program)
In some cases useful info is found in syslog - try
dmesg | tail or so

Mache ich das manuell über mount.cifs … klappts. Ich hätte es aber gerne in der FSTAB stehen oder klappt mein Vorhaben auch hier nicht?

Schönen Abend noch
Gruß Axel


Fremde Windows-Freigabe nutzen smbmount
#2

Wie ist denn der genaue Aufruf mit mount.cifs?


#3

Sorry für die späte Antwort.

Mein Befehl wann dann doch dieser hier…
mount -t cifs //10.0.0.1/zentrale/Seagate-Backup-Desk-01/ /fritznas -o username=axel.wickenkamp,password={PASSWORD},rw


#4

Na das sieht doch etwas anders aus. Hast du es schon mal so probiert?

//10.0.0.1/zentrale/Seagate-Backup-Desk-01/Batman /fritznas cifs uid=0,guid=0,rw,username=axel.wickenkamp,password={PASSWORD} 0 0

Oder auch so?

//10.0.0.1/zentrale/Seagate-Backup-Desk-01 /fritznas cifs uid=0,guid=0,rw,username=axel.wickenkamp,password={PASSWORD} 0 0

#5

Hallo SirTux,

leider klappt keiner von beiden :frowning:
letzte Fehlermeldung war…

mount: wrong fs type, bad option, bad superblock on //10.0.0.1/zentrale/Seagate-Backup-Desk-01, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program) In some cases useful info is found in syslog - try dmesg | tail or so


#6

Hi,

hab das Problem gelöst. Ich dachte ich hätte CIFS schon längst installiert, weil mount.cifs vorhanden ist. Leider falsch!
Ich musste das Repository unmaintained aktivieren und cifs-utils nachinstallieren, dann funktioniert es.

Danke SirTux, dass Du mir geholfen hast.

Schönen Start in die Woche.

Gruß Axel