Migration to mixed 5.0 and 4.4 possible or bad idea?

Dear community.

We are preparing for a migration from a Microsoft-based Active-Directory to UCS for some time already.
Now that we could start, UCS 5.0 would be available…

As some apps are not available in 5.0 yet, is it a good idea to start with a Primary with UCS 5.0 and secondary master as app-server running 4.4?
The idea is to start with a clean 5.0 domain, so that we do not need to worry about upgrading the primary DC later.

Any feedback would be welcome.