Mattermost - Login/Startseite öffnet sich nicht

german
installation
mattermost

#1

Hallo,

kürzlich habe ich einen Univention server aufgesetzt und sowohl Kopano Mail als auch Mattermost installiert. Während Kopano wie geplant läuft, lässt sich Mattermost zwar installieren, aber danach nicht weiter administrieren bzw. öffnen. Bei dem Versuch die Administrationsseite von Mattermost über die angelegte Kachel zu öffnen, öffnet sich ein neuer Browser-Tab - allerdings mit komplett “weißer” Seite.

Folgende Versionsdaten:
Univention Version: 4.2-3
Mattermost Version: 4.5

In den Log-Files im Docker-Container habe ich bereits nachgeschaut. Dort sind keinerlei Fehler oder sonstige sachdienliche Hinweise aufgeführt.
Bei der Installation von Mattermost habe ich sämtliche Konfigurationsfelder leer gelassen, damit die Standardeinstellungen von UCS übernommen werden.

Hat jemand dieses Problem bereits gehabt und gelöst oder kann mir jemand einen Hinweis geben, wo ich noch auf Fehlersuche gehen könnte?
Gerne stelle ich natürlich weitergehende Informationen zur Verfügung.

Vielen Dank
SundanceKid


English Version

Hello,

I have recently set-up a new Univention server and installed Kopano and Mattermost. While Kopano runs smoothly as desired, I am unable to even open Mattermost after installation (clicking on the added “Mattermost-Tile” opens a new browser tab - displaying a completely blank page).

Univention Version: 4.2-3
Mattermost Version: 4.5

In the log files (found in the docker container) I cannot see anything suspicious - there are no errors listed or any other hints/ messages.
For the installation, I have left all of the fields blank so the app would use the standard settings (of the UCS system).

Has anyone had this problem before or does anyone have an idea what would cause the mattermost config page to be blank?
Thanks for your help.

SundanceKid


#2

Hi @SundanceKid,

something I have noticed a few days ago is that on new installations the configure script was not run as expected. Can you go into the app open the app settings and just hit “apply changes”. this should then properly enable the proxy for Mattermost.


#3

Hi @fbartels,

thanks for your quick response.
Unfortunately, this did not resolve the issue - the browser page for mattermost is still “blank”.

Do you know of anything else that could cause the problem?

Thanks
SundanceKid


#4

hmm. strange…

so you go to https://your-ucs-system:8234 and just get a white page?

Apache logs to mattermost-access.log and mattermost-error.log, ist there anything in there? Just a blank page could also be something that would turn up in the error console of your browser.


#5

Exactly - to be precise I open https://subdomain.my-ucs-system:8234 and it then opens a new browser tab. This tab “loads” correctly, meaning the browser (Firefox) opens it and stops loading the page shortly after - without any error messages. Strangely enough, the page is not plain “white” but looks more like the slightly greyish background of the UCS Server. So in general, this all seems to go into the right direction.

Based on your hint, I looked into the apache mattermost-error.log and the mattermost-access.log. The error log does not contain anything. Whereas the access log contained several entries with GET /api/v4/subfolders (plugins, license, webapp) requests.

However, I tried to find this /api/v4 folder but could not find it on my system. Do you think this would be the root for the problem?

Thanks


#7

No that is not it, that path is provided by the mattermost binary. But i think you already have dropped the required hint what is going wrong: your’re using Firefox.

I recently learned that there is a known bug with Mattermost 4.5 and FIrefox 57. More details at https://mattermost.atlassian.net/browse/PLT-8456. If you install another browser to test, https://iridiumbrowser.de/ for example. Then you should find that Mattermost loads fine with that one.


#8

Sometimes the solution is so simple :wink:
Thank you very much @fbartels - it works with a different browser.