Mattermost Container wont run, need assistance

mattermost

#1

Hello there,

I cannot get my instance of mattermost to run after trying to reinstall it from the appcenter.
app center would not let me uninstall it as it said container was not running.
So I used the CLI

univention app remove --dot-not-backup to forcibly remove it and install it again from the app center.

docker log gets me the following output, it seems it has problems connecting to the inbuilt mysql database:

=> Preparing MySQL
[i] Setting up new power user credentials.

  • Starting MySQL database server mysqld
    …done.
    [i] Setting root new password.
    [i] Setting root remote password.
    mysql: [Warning] Using a password on the command line interface can be insecure.
    [i] Creating datebase: mattermost
    mysql: [Warning] Using a password on the command line interface can be insecure.
    [i] Create new User: USER with password PASSWORD for new database mattermost.
    mysql: [Warning] Using a password on the command line interface can be insecure.
    [i] Setting end,have fun.
    => Update Mattermost plugin directory
    => Start MySQL
  • Starting MySQL database server mysqld
    …done.
    => Start Kopano Web Meetings server
    time=“2019-07-31T16:29:15Z” level=info msg=“serve start”
    time=“2019-07-31T16:29:15Z” level=info msg=“serve started”
    time=“2019-07-31T16:29:15Z” level=info msg=“admin: API endpoint enabled”
    time=“2019-07-31T16:29:15Z” level=info msg=“rtm: API endpoint enabled”
    time=“2019-07-31T16:29:15Z” level=info msg=“starting http listener” listenAddr=“0.0.0.0:8778”
    time=“2019-07-31T16:29:15Z” level=info msg=“ready to handle requests”
    => Start Mattermost
    {“level”:“info”,“ts”:1564590558.9249542,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’”}
    {“level”:“info”,“ts”:1564590558.925678,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initializing…”}
    {“level”:“info”,“ts”:1564590559.0035865,“caller”:“sqlstore/supplier.go:219”,“msg”:“Pinging SQL master database”}
    {“level”:“info”,“ts”:1564590576.3313568,“caller”:“sqlstore/upgrade.go:116”,“msg”:“The database schema has been set to version 5.10.0”}
    [mysql] 2019/07/31 16:30:30 packets.go:36: read tcp 127.0.0.1:55080->127.0.0.1:3306: i/o timeout
    {“level”:“error”,“ts”:1564590631.5011747,“caller”:“sqlstore/supplier.go:811”,“msg”:“Failed to create index invalid connection”}
    {“level”:“info”,“ts”:1564590632.7745478,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’”}
    {“level”:“info”,“ts”:1564590632.7749052,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initializing…”}
    {“level”:“info”,“ts”:1564590632.8306193,“caller”:“sqlstore/supplier.go:219”,“msg”:“Pinging SQL master database”}
    {“level”:“error”,“ts”:1564590662.8456335,“caller”:“sqlstore/supplier.go:162”,“msg”:“Error creating database tables: context deadline exceeded”}

#2

A similar message has been reported in Mattermost Update 4.9.0 failed as well, but I have never seen the error myself.

Is there data in the database or did you try to start over? Maybe over in the Mattermost forum they have a more concrete idea.


#3

Thank you for answering.
I was indeed trying to start over.
It worked for a short while, but when I tried to integrate mattermost into the kopano webapp via plugin something broke and no connection is possible to the mattermost service. webapp / webmeetings still work fine without problems.
I will check out that other thread and maybe the mattermost forums.