Manually installed certificates are marked as invalid

I installed certificates created from our ca into UCS, previously it was using the self-signed certificates from UCS. They seem to work fine in the browser and all pages (nextcloud, …) are reachable via https.
But I get the followiing error from the UCS checks:

Ungültiges Zertifikat ‘/etc/myssl/cert.pem’ gefunden: error /etc/myssl/cert.pem: verification failed

What could be the reason for this? I installed them with the ucr commands for apache2. We are using the certificates on multiple other machines without problems.

Also the adconnector seems to have stopped working. New users and groups create in the active directory aren’t showing up in UCS.

Just solved the certificate issue with the following post: System Diagnostics - Check Validity Of SSL Certificate

I needed to install the root-certificate.

Although the changes from the active directory are still not showing up in UCS. The connector log shows the following error repeatedly:

try to sync 45 changes from UCS
done: Tue Apr 14 10:09:29 2020
 --- connect failed, failure was: ---
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/univention/connector/ad/", line 302, in main
  File "/usr/lib/python2.7/dist-packages/univention/connector/ad/", line 204, in connect
  File "/usr/lib/python2.7/dist-packages/univention/connector/", line 877, in initialize_ucs
  File "/usr/lib/python2.7/dist-packages/univention/connector/", line 964, in poll_ucs
  File "/usr/lib/python2.7/dist-packages/univention/connector/", line 939, in _generate_dn_list_from
    dn, new, old, old_dn = cPickle.load(f)

 ---     retry in 30 seconds      ---